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Tables

1.0 Revision history 

2.0 Definition

This document describes the workflow for creating and editing tables in Anna. 

3.0 Terms and keyboard conventions

The following keyboard conventions are used in this document: 

• Alt refers to both the Alt key in Windows and the Option key in Mac OS.

• Ctrl refers to both the Ctrl key in Windows and the Command key in Mac OS. (Note
that this does not usually refer to the Mac OS Control key. The Macintosh Control key
is used in the Adobe user interface standards only in the Control-click gesture to access
context menus.)

• Enter refers to both the Enter key in Windows and the Return key in Mac OS.

An example of a margin note. Text in the margin (see left) is either a note to reviewers, an undecided issue, or a product-
specific exception. 

Date Name Description of changes

7/20/200 J. Cutler First version
8/9/2000 J. Cutler Added some extra detail and art to first version; still many areas to be defined.

9/12/2000 S. Dunn Made changes based on comments from J. Aguirre and new decisions by engineering team
11/2/2000 S. Dunn Made lots of changes based on evolving realities.

11/12/2000 S. Dunn Began incorporating changes requested by Z. D. Williamson and D. Bessette and others
11/16/2000 S. Dunn Incorporated changes based on mini-review meeting.
11/30/2000 S. Dunn Added new screen shots and text for revised Table Options dialog; added section on context menus
12/20/2000 S. Dunn Completed post-review revisions and addition of new and corrected mockups provided by J. Aguirre.

1/24/2001 S. Dunn Added additional tweaks and updated dialog box mockups from J. Aguirre, based on beta feedback.
5/17/2001 J. Aguirre Revised based on recent table team UI meeting decisionns
6/21/2001 S. Dunn Revised based on comments from M. Hille, D. Bessette, and remarks from table team.
6/26/2001 S. Dunn Added info on click-selecting column and resolved a final few issues.
7/10/2001 J. Aguirre Corrected the order of tabs displayed in the Table Options dialog box.
7/11/2001 S. Dunn Corrected  Alt-dragging to add new rows & columns; new table palette mockups with final versions provided by J. Aguirre
7/13/2001 S. Dunn Added a section on resizing selections with merged cells and retouched the section on arrow-key navigation.

8/6/2001 J. Aguirre Made several corrections in accordance with bugs logged by QA.
8/7/2001 S. Dunn Corrected pictures of Table Options dialogs; fixed context menu section; made other minor changes from J. Aguirre.

8/14/2001 S. Dunn Removed margin notes and referred readers to keyboard shortcut spec for that information.
8/14/2001 S. Dunn More changes: Split cells works with multiple selection; cursor section fixed; stroke issue clarified, feedback UI meeting
9/18/2001 S. Dunn Changed the range of values acceptable for Space Before for Tables (0 to 720p).
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5.0 Creating tables

Creating a table is a two step process: First, users must either create a new text frame (for 
example, by dragging with the type tool) or click an insertion point in an existing text frame 
(including inside a table). Next, users must choose Table > Insert Table from the menu bar. 
As you would imagine, this command opens the Insert Table dialog box.

Figure 1: Choosing Table > Insert Table opens this dialog box.

To facilitate the quick creation of simple tables, this dialog includes only two text boxes for 
manually typing in the number of rows and columns.

Rows: Lets users specify the initial number of rows for the table. The default is 4.

Columns: Lets users specify the initial number of columns for the table. The default is 4.

If the user enters a value that is outside the acceptable range, an error message appears as 
soon as that text box loses focus. The error message box points out the error and lists the 
acceptable values.

When the user clicks OK, InDesign creates a table with the specified number of rows and col-
umns inside the current text. The new table fills the entire width of the container text frame 
starting on the same line (if the cursor is at the beginning of the line) or the next new line 
(otherwise). The height of the new table is equal to the number of rows multiplied by the 
height of each row. The default height of each row is equivalent to the slug of the current text 
attributes at the insertion point. In effect, each empty cell contains one carriage return. The 
newly created table has an active insertion point in the first (top left) cell.

Tables exists in the flow of surrounding text just like an inline graphic. For example, the table 
moves through threaded frames as the text above it changes size or quantity. One exception 
occurs in the case of text-on-path frames: If table flows into a text-on-path frame or attempts 
to create a table in such a frame, the table will not appear but will instead flow to the next 
threaded frame (if one exists) or appear as overset text. The actual location of the table in the 
text flow is the table anchor. This anchor is neither visible nor selectable.
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6.0 Table defaults

Unlike many features in InDesign, the commands on the Table menu and its submenus are 
not available when no document is open. Consequently, users cannot use this method to set 
application-level defaults for creating and formatting tables.

The Insert Table dialog does remember the last used settings (number of rows and columns) 
each time it is opened, whether in the current document or in a new document. However, 
the commands in the Table Options and Cell Options dialog boxes are not saved; these dialog 
boxes always display the shipping defaults for a new table or the settings of the currently 
selected cells or table (or no settings for a selection of mixed attributes). For example, a new 
table will always have cells with a fill of [None] and a Black 1 point stroke on cell borders. For 
more information on these dialog boxes, see “Modifying tables using Table Options and Cell 
Options dialog boxes” on page 16.

7.0 Cell content and its behavior

Table cells behave much like text frames. For example, like text frames, table cells can contain 
the following:

• One or more paragraphs of text

• inline graphics

• other text frames

• other tables

Table cells differ from text frames, however, in the following ways:

• Users cannot thread content from one cell to another.

• Cells have the ability to grow automatically as content is added. For example, in Roman 
versions of InDesign, a row of cells will grow vertically to accommodate content added 
to one or more cells in that row. (The direction of grow depends on the direction of the 
story flow.)

7.1 Adding content Users can add content to table cells using the following methods, all of which require the type 
tool be active:

• Clicking (or selecting text) in a cell and using the File > Place command.

• Clicking (or selecting text) in a cell and using the Table > Insert Table command.

• Clicking (or selecting text) in a cell and typing.

• Creating a table from existing text using the “Convert Text to Table” command (see 
page 32).

• Pasting text or an individual frame or graphic from the Clipboard.

• Pasting one or more InDesign table cells from the Clipboard. See “Cut, copy, and paste” 
on page 16.

• Using XML. For more information, see the XML functional specification.
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7.2 Content fitting As a user adds content to a table cell, the cell grows vertically as much as needed to accom-
modate the content. This default behavior is optional, however. Users can place limits on 
how much a cell can grow or prevent it from growing at all. For more information, see “Row 
Height drop-down list” on page 22

If a table cell is set to a fixed or limited size, text added to the cell may not fit. An adornment 
to the text cell indicates that some text cannot be displayed. This adornment is like the over-
set marker in text frames in that it appears on screen but never in printed output. However, 
unlike an overset condition, users cannot click this adornment and place the remaining text 
elsewhere as a threaded text frame.

Figure 2: A special icon indicates an overset table cell.

Although table cells grow vertically by default, the horizontal width of cells does not auto-
matically change size in response to content. (Cell width can be adjusted by users, of course; 
see “Resizing” on page 13 and “Apply formatting to an entire table” on page 25.) However 
the case of inline graphics presents a special situation. If a cell has enough vertical height to 
accommodate the graphic, it will appear in the cell, even if the cell is not wide enough to 
accommodate the entire graphic. The graphic will extend beyond the right side of its con-
tainer cell. If the cell has insufficient vertical height to accommodate the graphic, an overset 
situation is indicated as shown above.

It is also possible for text or inline graphics to extend beyond any or all cell edges if the lead-
ing is small enough to prevent an overset condition but the text formatting or inline graphic 
dimensions cause it to exceed the size of a container cell. By default, the text or graphic will 
simply extend beyond the edge of the cell, and cell strokes (if present) will appear on top of 
this extended material. However, if users desire to clip the content so that none of it appears 
outside the cell boundary, they can choose“Formatting row height and column width” in the 
Text section of the Table Options dialog box. See “Formatting text in table cells” on page 17.

Note that if you create a table within a cell, any parts of the table that hang outside the cell 
boundary will not be selectable with the mouse.

Though not strictly related to cell content, a related issue is how container text frames 
accommodate tables that are larger than the frame dimensions. By default, new tables are 
created to fill the width of the current text frame. However if the table’s width is enlarged or 
the container text frame’s width is reduced, part of the table will appear beyond the edge of 
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the text frame (similar to the way large inline graphics appear in narrow table cells). The table 
will stick out to the right in a left-aligned paragraph, to the left in a right-aligned paragraph, 
and so on.

Figure 3: Like inline graphics, tables too wide for their container text frame will hang outside 
the left, right, or both sides of the frame depending on the alignment of the paragraph.

If a table’s vertical dimensions are larger than the height of the container text frame, one or 
more bottom rows of the table are moved into the next text frame in the thread that can 
accommodate the height of the row(s). If no such threaded frame exists, an overset condition 
is created. Rows move into threaded frames (or into an overset state) one at a time, just as 
lines of type do. It is not possible to break a single row across multiple frames.

For problems relating to tables too large for their containers, see “Losing tables in overset 
conditions” on page 43.

7.3 Cell and row 
navigation

Users can navigate from one cell to the next using the keyboard. Pressing the Tab key 
advances the insertion point or selection highlight from one cell to the next, left to right, top 
to bottom. If a cell has content, tabbing into the cell selects all the text in that cell. Otherwise, 
tabbing into a cell places the insertion point there. Pressing Shift+Tab reverses the direction 
in which the insertion point or selection highlight moves. If the user is in the last cell of a 
table (bottom right corner for Roman languages), pressing Tab will create a new row and 
move the insertion point to the first cell in that row. If the user is in the first cell of a table 
(top left corner for Roman languages), pressing Shift+Tab moves the insertion point or selec-
tion highlight to the last cell in the table.

Users can also move the insertion point through the table by using the arrow keys. Note these 
behaviors:

• Pressing the left and right arrow keys moves the insertion point one character to the left 
or right, respectively, just as with text.

• If the insertion point is at the beginning of a cell, pressing the left arrow key moves the 
insertion point to the previous cell. If the insertion point is at the end of a cell, pressing 
the right arrow key moves the insertion point to the next cell.

• If the insertion point is at beginning of the first (top left) cell of a table, pressing the left 
arrow will move the insertion point before the table, allowing users to add text above a 
table that may be abutting the top of its container frame. (Users could also click below 
the table and then press the Left arrow.) 

• However, a user cannot use arrow keys to navigate out of the last cell of a table.

• No keyboard maneuver allows users to move the insertion point into a table from the 
surrounding text. Arrowing through text containing a table simply skips over the table. 

Right-aligned paragraph Center-aligned paragraph Left-aligned paragraph
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• If the insertion point is in text in a cell, pressing the up arrow moves the insertion point 
up one line (if the cell has multiple lines) or to the beginning of the cell’s content (if it 
has only one line or the insertion point is in the top line). Pressing the up arrow again 
moves the insertion point to the end of the content of the cell immediately above. The 
down arrow key behaves in the reverse manner.

• The left and right arrow keys only allow navigation with the row containing the 
insertion point. If the insertion point is at the leftmost position in the leftmost cell of a 
row, pressing the left arrow again cycles the insertion point to the last position in the 
rightmost cell in that row. Conversely, pressing the right arrow when the insertion 
point is at the far right position moves the insertion point to the first position in the 
leftmost column.

• When Shift is added to the arrow keys, the insertion point (or selection highlight in this 
case) does not cycle; pressing Shift + left arrow in the first position may select the cell 
(if it’s not already selected) but doesn’t move the insertion point or highlight any 
further. Conversely, pressing Shift + right arrow in the last position may select that cell 
(if it wasn’t already selected) but doesn’t move the insertion point or selection highlight 
anywhere else.

• Similarly, the up and down arrow keys only allows navigation within the column 
containing the insertion point. Pressing the up arrow key when the insertion point is in 
the top line of the top row cycles the insertion point to the last position of the bottom 
cell in that column. Conversely, pressing the down arrow key when the insertion point 
is in the last position in the bottom row cycles the insertion point to the first position in 
the top cell in that column.

• As with rows, adding Shift to this behavior prevents cycling. Pressing Shift + up arrow 
in the first position may select the cell (if it’s not already selected) but doesn’t move the 
insertion point or highlight any further. Conversely, pressing Shift + right arrow in the 
last position may select that cell (if it wasn’t already selected) but doesn’t move the 
insertion point or selection highlight anywhere else.

Users can also jump to a desired row number by choosing Table > Go to Row, entering the 
desired row number in the Go to Row dialog box, and pressing Enter or clicking OK. This 
will be especially helpful for users who create large, multi-page tables.

Figure 4: The Go to Row dialog box

Cell navigation is also discussed in a related functional specification, found in the appropri-
ate Engineering section of the InDesign 2.0 Intranet site. For more on table selection, see the 
following section.

8.0 Selection issues

InDesign 2.0 tables follow the “select-do” model common to most modern word-processing 
applications in which the user must first select all or part of a table before performing some 
action (such as editing or formatting) on that selection. Nevertheless, InDesign does make 
some exceptions to this model. For example, resizing rows, columns, and entire tables by 
dragging does not require prior selection nor affect any existing selection.

http://indesign-projects.sea.adobe.com/Anna/Documents/Functional%20Specifications/Tables/091200_TablesS&K8x11_v48.pdf
http://indesign-projects.sea.adobe.com/anna/Documents/docsListing.asp?Dir=Functional%20Specifications&Home=Functional%20Specifications&Desc=FUNCTIONAL%20SPEC%20DOCUMENTS&BaseInc=Features/SpecReviewers.htm&Detailed=Functional%20Specifications
http://indesign-projects.sea.adobe.com/anna/Documents/docsListing.asp?Dir=Functional%20Specifications&Home=Functional%20Specifications&Desc=FUNCTIONAL%20SPEC%20DOCUMENTS&BaseInc=Features/SpecReviewers.htm&Detailed=Functional%20Specifications
http://indesign-projects.sea.adobe.com/anna/
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Note that all selections in a table must have a rectangular shape. It is not possible to select 
discontiguous cells nor cells to form a selection of any other shape (such as a cross or an “L”). 
The only exception to this is when a selection includes one or more merged cells. The merged 
cells may lie outside the rectangular shape, creating a selection that is not rectangular in 
appearance. See “Merge Cells” on page 34.

8.1 Text selection 
versus cell selection

Whether a user wants to format the text in multiple table cells or the cells themselves, the 
process of selection is the same. This process requires the type tool (and only that tool). 
Whether all the text in a cell is selected (with a text selection highlight) or the cell is selected 
(with the selection highlight filling the cell), changing values in the Character palette or Para-
graph palettes will affect the text in that cell.

A special cases exists when formatting the stroke and fill of a cell versus formatting the stroke 
and fill of the text inside a cell. The text or object control on the toolbox, Swatches palette, 
and Color palette determines whether fill and stroke formatting affects the text or the cell.

Figure 5: The text or object control appears in multiple convenient locations.

For example, if one or more table cells are selected and the text or object control is set to con-
tainer (the default), applying a new fill and stroke color affects only the selected cells, not the 
fill and stroke of the text inside those cells. On the other hand, if the text or object control is 
set to text, applying a new fill and stroke color affects only the fill and stroke of the text but 
has no effect on the color of the selected cells. 

Figure 6: Blue stroke and yellow fill applied to cell selected with the fill and 
stroke control set to object (left) and set to text (right)

Text or object control
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In either case, users can also apply gradients to the fill or strokes of cells or text (depending 
on the state of the text or object control. Note that if the text or object control is set to con-
tainer and a gradient is applied to a cell’s stroke, users cannot use the gradient tool to remap 
the gradient of individual sides of that cell; the tool only works simultaneously on all sides of 
the cell stroke that have a gradient. This is so even if the different sides of the cell stroke have 
different gradients (using the Cell Options or Table Options dialog box as described in “For-
matting cell strokes and fills” on page 19). For more on tables and gradients, see the “Inter-
action with tables” section of the InDesign Gradient specification. For more on the text or 
object control, see the Text or Object Control specification.

8.2 Selection 
appearance

When part or all of the text in a cell is selected, that text has the same appearance as selected 
text that is not in a table. However, if multiple cells are selected, the selection highlight fills 
all selected cells.

Figure 7: Selection highlight fills all selected cells.

8.3 Selecting cells by 
clicking and dragging

Users can select table cells by clicking in special locations or by dragging over the desired cells 
using the type tool.

8.3.1 Drag-selecting cells
The behavior is similar to dragging a selection marquee around icons in Windows Explorer 
or Mac OS Finder, except that the selection marquee is replaced with highlighted table cells 
and the selection highlight snaps to individual cells. In addition, when the drag action begins 
in a cell, the selection highlight begins as a text selection and then changes to cell selection 
once the pointer reaches the cell boundary. The natural consequences of this behavior are as 
follows:

• Dragging horizontally selects additional cells in the current row in the direction of the 
drag.

• Dragging vertically selects additional cells in a column in the direction of the drag.

• Dragging diagonally selects additional cells in other rows and columns in the direction 
of the drag.

• Reversing the direction of the drag after already selecting some cells deselects cells once 
the pointer moves outside the cell boundaries.

Note that dragging the type tool inside a single table cell initially selects characters under the 
pointer. However, if the user continues to drag so that the type tool pointer passes beyond 
the cell boundary, the entire cell is selected with the bold border. Continuing to drag into 
neighboring cells does not select additional individual characters but only adds more whole 

http://indesign-projects.sea.adobe.com/anna/ui/pdf/InDesign_gradients2.pdf
http://indesign-projects.sea.adobe.com/anna/ui/pdf/toolbox_text_ctrl_v3.pdf
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cells to the selection. Consequently, it is not possible to select part of the text in multiple cells. 
For example, the user cannot select the text in 2.5 cells. Reversing the direction of the drag 
can return a cell selection back to a text selection or insertion point.

Figure 8: Dragging to the right with the type tool selects text (top);
continued dragging selects one or more cells (bottom).

Note: When changing from a text selection to a cell selection, the user must drag the 
pointer hot spot (baseline of the text I-beam) within three pixels of the first cell’s border. 
Thereafter, dragging the hot spot into a cell is sufficient for selecting that cell.

Finally, note that users cannot select one or more cells in addition to text that comes either 
before or after the table:

• Starting with an insertion point, text selection, or cell selection in a table and dragging 
below the table may select cells down to the bottom of the table but will not select any 
text below the table.

• Starting with the insertion point or text selection in text before a table and dragging 
into the table does not select any cells but selects the entire table as a character (like an 
inline graphic). None of the normal table formatting options are enabled in this 
situation.

8.3.2 Click-selecting using modifier keys
In addition, users can use modifier keys to click-select multiple cells or a range of cells.

To select a range of cells, the user selects the type tool, selects a cell at the beginning of the 
desired range, and then Shift-clicks the last cell in the range. If the location of the second click 
forms a diagonal line from the first click, a rectangular range of cells in multiple rows and 
columns is selected. The user can also Shift-click again to add to or subtract from the range, 
depending on whether the click is outside or inside the existing selection, respectively.

When a user click-selects an entire row, column, or table (as described below), the cell closest 
to the click becomes the “anchor” for the selection (not the same as the table anchor in the 
flow of text). Subsequent Shift-clicking in the table forms a rectangular selection extending 
from the anchor point to the last Shift-click location.

Users cannot extend a selection from an insertion point inside a cell to text wholly outside 
the table. If the user has an insertion point or text selection in a cell and then Shift-clicks in 
text that is outside of the table, no cells are selected. Instead, the insertion point is reposi-
tioned at the Shift-click location.
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Currently, beginning with an insertion point or text selection in a table cell and Shift-clicking 
another cell in the same table does not result in multiple cell selection. This may be changed, 
but it is considered an opportunistic feature.

8.3.3 Click-selecting entire rows and columns
As a shortcut for selecting an entire row or column, the user can position the type tool 
pointer along the outside edge of a table and click. Clicking along the top table edge selects 
the column closest to the pointer. (This selects the entire column, even if part of it is threaded 
into other frames.) Clicking along the left table edge selects the row closest to the pointer. 
Clicking the bottom or right edges does not result in a column or row selection.

The pointer must be directly over or just inside the cell boundary. Clicking just outside the 
table edge will have no effect. When the pointer is in the proper position to engage this fea-
ture, a special pointer appears. See “Pointers/cursors” on page 36.

Figure 9: Clicking the left edge of a table (top) selects the entire row (bottom).

In addition, once the pointer is in the proper position, users can drag vertically to select mul-
tiple contiguous rows. Multiple-row selection is also possible using the Shift key while click-
ing in this area. For example, Shift-clicking a table edge after selecting a row or column with 
this method selects all rows or columns in between, respectively. Shift-clicking again either 
adds to or subtracts from the selection, depending on whether the pointer is outside or inside 
the existing selection, respectively. Users cannot mix row and column selection when Shift-
clicking. If the user selects a row and then Shift-clicks a column, the row selection is dis-
carded and the column is selected instead. Only row ranges and column ranges are sup-
ported.

Note that if the table contains split or merged cell, it may be difficult for the user to predict 
which cells will be selected. In these cases, column selection is based on the underlying table 
grid.

Figure 10: Merging and splitting cells affects click-selecting of columns

8.3.4 Click-selecting entire tables
As a shortcut for selecting an entire table, the user can position the pointer over the outside 
edge of the table of the top left corner and click the table border. Technically, this selects all 
cells, since that is the only way to apply table formatting.
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8.4 Selecting cells 
using the menu

The Table menu on the main menu bar includes commands for selecting discrete table sec-
tions, such as cells, rows, columns, or an entire table. The process involves two steps: First, 
the user gives the focus to the table by selecting one or more cells with the type tool, or by 
clicking a text insertion point in the table using the type tool. Second, the user chooses a 
command from the Table > Select submenu. All commands on the select submenu are dis-
abled if current selection or insertion point is not in a table. For more information on menu 
commands, see “Table menu” on page 32.

8.5 Keyboard 
selecting

If the user clicks an insertion point in text in a table, she can use the conventional 
Shift+arrow key shortcuts to select text within that cell. Once the selection highlight reaches 
the beginning or end of text in that cell, the next Shift+arrow keystroke changes from a text 
selection to a cell selection. Continued repetitions of those keystrokes selects additional cells, 
left to right, top to bottom (one cell per Shift+arrow keystroke). Pressing Shift plus the oppo-
site arrow key with only a single cell selected returns to a text selection.

InDesign 2.0 will have a keyboard shortcut that allows the user to toggle between selecting 
all the contents of a cell and selecting the cell itself. For information, see the keyboard short-
cut spread sheet on the Annapurna intranet site.

When a single cell has an insertion point or text selection, pressing Ctrl+A selects all the text 
in the cell. However, if one or more cells are selected, pressing Ctrl+A selects all the cells in 
the table.

8.6 Deselecting An existing selection will be lost if the user does any of the following:

• Clicks anywhere in the document window without pressing Shift.

• Clicks or Shift-clicks outside the current table.

• Chooses Edit > Deselect All

• Selects a tool in the toolbox other than the following: type, path type, eyedropper, 
gradient, hand, zoom.

9.0 Modifying tables using commands and gestures

InDesign provides a number of different ways for users to add and remove rows and col-
umns; change the size of rows, columns, and entire tables; and change the stroke and fill of 
cells. To make many changes at once, InDesign provides comprehensive editing and format-
ting dialog boxes available via the Table > Table Options and Table > Cell Options submenus. 
These are discussed in “Modifying tables using Table Options and Cell Options dialog boxes” 
on page 16. But for specific changes, it is often simpler to use the individual commands or 
mouse and keyboard shortcuts addressed in this section.

9.1 Basic formatting As suggested earlier, users can format the text in any selected cells by using the normal text 
formatting tools such as the Character and Paragraph palettes, or by setting the text or object 
control in the toolbox to text mode and then using various color controls to change the text’s 
fill and/or stroke (see “Text selection versus cell selection” on page 8). Similarly, users want-
ing simply to format the fill and stroke of selected cells can use the toolbox to invoke con-
tainer mode and then use the normal tools for modifying these elements, such as the Stroke, 
Swatches, and Color palettes.
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For information on applying gradient fills to tables, see the “Interaction with tables” section 
of the InDesign Gradient specification. For information on using the eyedropper tool with 
table formatting, see the “Interaction with tables” section of the Eyedropper Tool in InDe-
sign specification. Both these documents can be found on the InDesign 2.0 User Interface 
intranet site.

However, users are not limited to these techniques, which could become quite burdensome 
for complex formatting of a large table. To achieve effects such as alternating fill and stroke 
patterns, InDesign special commands and dialog boxes. For additional information, see 
“Modifying tables using Table Options and Cell Options dialog boxes” on page 16. 

9.2 Resizing Resizing rows, columns, and entire tables is similar to resizing other graphic objects created 
in InDesign. However, tables do present some unique circumstances. For a summary of 
resizing techniques, see “Gestures and keystrokes for table resizing” on page 39.

9.2.1 Resizing a row or column
Users can resize a row or column by dragging a horizontal or vertical cell border, respectively. 
Doing so actually resizes the entire table, since the table size is the sum or its rows and col-
umns. Dragging a horizontal line affects the row above the pointer. Dragging a vertical line 
affects the column to the left of the pointer. The remaining rows or columns are moved left 
or right, up or down, changing the dimensions of the entire table. Dragging the left or top 
edges of a table has no effect.

The hot zone (“draggable” area) is never smaller than 3 pixels, even when the user has 
zoomed out. When dragging a row or column border, the pointer becomes a two-headed 
arrow to signal the resizing effect.

Figure 11: Dragging a horizontal border resizes the row above.

Figure 12: Dragging a vertical border resizes the column to the left of the pointer.

Note that the drag-resize technique operates independently of the current selection (if any). 
example, a user may have selected row 4 of a table while resizing column 1. The row remains 
selected during and after the resizing operation until the user deselects it.

To resize rows and columns without affecting the overall outside dimensions of the table, the 
user holds down the Shift key and then drags the cell border. Shift-dragging a cell border 
affects two rows or two columns, since one row or column gets bigger as the other gets 
smaller.

In the case of columns, resizing works by changing the value for “Column Width” in the 
Rows and Columns panel of the Table Options dialog box. In the case of rows, resizing 
changes the value accompanying the “Row Height drop-down list” in the Rows and Columns 
panel of the Table Options dialog box. As long as the size change does not result in any over-

http://indesign-projects.sea.adobe.com/anna/ui/pdf/InDesign_gradients2.pdf
http://indesign-projects.sea.adobe.com/anna/ui/pdf/tools_id_eyedrop.pdf
http://indesign-projects.sea.adobe.com/anna/ui/pdf/tools_id_eyedrop.pdf
http://indesign-projects.sea.adobe.com/anna/UI/index.html
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set text (as would happen if the user shrinks the row so that it can’t accommodate the text in 
one or more cells), the option selected in the Row Height drop-down list (At Least or 
Exactly) does not change. However if the user’s action makes one or more cells too small to 
accommodate existing text, the Row Height option is set to Exactly (to prevent autogrow 
from overriding the desired size), and an overset condition is created. See “Formatting row 
height and column width” on page 22.

9.2.2 Resizing both rows and columns
Resizing a table is similar to resizing a row or column. The user simply drags the bottom right 
corner of the table to increase or decrease its size, similar to resizing a rectangle drawn in 
InDesign. Holding down the Shift key maintains the table’s aspect ratio during resizing. 
Note, however, that this feature is disabled if the table flows into more than one frame.

9.2.3 Resizing and merged cells
If one or more cells have been merged to neighboring cells using the “Merge Cells” com-
mand, the column width or row height shown in the Cell Options dialog box or Table palette 
is that of the narrowest or shortest cell in the selection, respectively. For example, if the selec-
tion includes three merged cells in one row and two merged cells in another row, the column 
width displayed is the width of the two merged cells. Similarly, if the selection includes a non-
merged cell, that cell’s width or height would be displayed. Furthermore, it is this narrowest 
column or shortest row to which any changes in column size or row height are applied. In 
the case of merged cells, the changes are distributed proportionally among the columns or 
rows in the selection.

9.3 Insertion InDesign 2.0 includes features for adding additional rows and columns to an existing table.

9.3.1 Inserting a new row
Once a cell is selected, the user may add a new row by choosing Table > Insert > Row. This 
command is disabled unless the selection highlight or insertion point is in a table.

This command displays a dialog box prompting the user to specify how many rows will be 
added and whether to create the new rows above or below the current selection. The default 
settings are 1 for Number and Above for location.

Figure 13: The Insert Row(s) dialog box lets you specify how many rows to add and where

The cells in newly added rows have the same formatting (fills, strokes, text, and so on) as the 
cells in the neighboring row—in other words, the same as the row below (if Above is chosen) 
or the row above (if Below is chosen).
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9.3.2 Inserting a new column
Once a cell is selected (using any method), users can add new columns by choosing Table > 
Insert > Column. This command is disabled unless the selection highlight or insertion point 
is in a table.

This command displays a dialog box prompting the user to specify how many columns will 
be added and whether to create the new columns to the left or right of the current selection. 
The default settings are 1 for Number and Left for location.

Figure 14: The Insert Column(s) dialog box lets you specify
how many columns to add and where

Cells added with this method have the same formatting (fills, strokes, text, and so on) as the 
neighboring column—in other words, the same as the column on the left (if Right is chosen) 
or the column on the right (if Left is chosen).

9.3.3 Inserting rows and columns by dragging
Users can also add new rows and columns by positioning the pointer over a column or row 
boundary, pressing and holding the mouse button, and then Alt-dragging down or to the 
right, respectively. Alt-dragging a column edge creates one or more new columns; Alt-drag-
ging a row edge creates one or more new rows. Note the following aspects of this feature:

• If a user Alt-drags a table edge a distance equal to one and half times the copied row 
height or column width, a second new row or column are created.

• When adding multiple rows or columns by dragging, the new rows or columns have the 
same height or width settings, respectively, as the row above or column to the left of the 
edge being dragged.

• If the row above the horizontal edge being dragged has a row height setting of At Least, 
the new rows have the same height settings as the row above the dragged edge.

• If the row above the horizontal edge being dragged has a row height setting of Exactly, 
dragging to add a single row creates a row with the Exactly attribute but with a row 
height equal to the distance dragged (up to one and half times the row height; beyond 
that point, multiple rows are created).

• This feature does not work for the top or left edges of a table.

• For the bottom or right edge of a table, the user can drag upward to delete rows or drag 
left to delete columns (or both by dragging the bottom right corner). 

• The user must press the mouse button before pressing Alt, since pressing Alt first 
temporarily activates the hand tool.

• Other formatting (fill, stroke, text attributes and so on) is copied from the column on 
the left or the row above.
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9.4 Deletion As you would expect, InDesign 2.0 not only includes commands for adding new rows and 
columns to an existing table, but deleting unwanted rows and columns as well. If a user 
selects one or more table cells and presses the Delete key, chooses Edit > Clear, Edit > Cut, 
or presses Ctrl + X, only the contents of the table cells (text and/or inline graphics) are 
deleted. Table rows or columns themselves can only be deleted using the commands on the 
Table > Delete submenu or the context menu.

For more details on the Delete menu, see “Delete” on page 34.

9.5 Cut, copy, and 
paste

The interface issues surrounding cutting, copying, and pasting tables and parts of tables are 
discussed in a separate specification, Table Cut/Copy and Paste, by Lisa Andrews. This doc-
ument is available in the Engineering: Specs and Documentation section of the Annapurna 
intranet site.

10.0 Modifying tables using Table Options and Cell Options dialog boxes

To achieve more complicated formatting effects with a minimum of effort, InDesign 2.0 
includes multi-panel Cell Options and Table Options dialog boxes. Each panel can be 
opened directly using the appropriate command on the Table > Cell Options or Table > 
Table Options submenus. Once each dialog is opened, navigation to other panels is available 
by clicking a tab at the top (the new standard UI for dialog boxes with fewer than five panels).

The commands that open the Cell Options and Table Options dialog boxes are only enabled 
when a table has a text insertion point (or text selection) inside a cell or has one or more cells 
selected.

10.1 Scope of 
individual panels

The Cell Options dialog box affects two distinct areas:

• The Rows and Columns panel applies to all rows or all columns (or both) intersected 
by the current selection or insertion point, even if only a portion of a row or column is 
selected or has only an insertion point.

• The remaining panels listed (Text, Strokes and Fills, and Diagonal Lines) affect only 
selected cells or a cell containing an insertion point or text selection.

The Table Options dialog box, on the other hand, works globally: Its controls affect the entire 
table, even if only a portion of the table is selected or has only an insertion point.

10.2 Formatting 
priorities

Because the Table Options dialog box provides multiple ways in which the user may apply 
different strokes and fills to table cells, it is useful to understand how these settings in differ-
ent panels interact. The following list shows the priority order of stroke settings:

• Cell stroke (Cell Options, Stroke and Fills panel; see “Formatting cell strokes and fills” 
on page 19)

• Table border (Table Options, Table Setup panel; see “Apply formatting to an entire 
table” on page 25)

• Alternating Stroke (Table Options, Row Strokes panel; see “Formatting alternating 
strokes and fills” on page 26)

The following list shows the priority order of fill settings:

• Cell fill (Cell Options, Stroke and Fills panel; see “Formatting cell strokes and fills” on 
page 19)

http://indesign-projects.sea.adobe.com/Anna/Documents/Functional%20Specifications/Tables/091200_TablesCCP8x11_v48.pdf
http://indesign-projects.sea.adobe.com/anna/Documents/docsListing.asp?Dir=Functional%20Specifications&Home=Functional%20Specifications&Desc=FUNCTIONAL%20SPEC%20DOCUMENTS&BaseInc=Features/SpecReviewers.htm&Detailed=Functional%20Specifications
http://indesign-projects.sea.adobe.com/anna
http://indesign-projects.sea.adobe.com/anna
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• Alternating Fill (Table Options, Fills panel; see “Formatting alternating strokes and 
fills” on page 26)

Note that merely setting one of the higher priority items to a fill or stroke of “[None]” does 
make lower priority formatting visible, but merely overrides lower priority items with the 
[None] attribute. To prevent an override from obscuring lower priority formatting, the user 
must either turn off the feature (in the case of the Table border) or use the Preserve Local 
Formatting checkbox (in the case of alternating strokes or fills). See “Preserve Local Format-
ting” on page 26 and “Preserve Local Formatting” on page 30.

10.3 Common 
controls

Common to all tabbed panels in both Cell Options and Table Options are the following con-
trols:

OK: Close the dialog box and applies the changes made in all panels to the table containing 
the insertion point or to the selected cells.

Cancel: Closes the dialog box without applying any changes. Changes made to dialog box 
controls are discarded.

Preview: When checked, temporarily applies the changes made in the Table Options dialog 
box to the table or selected cells in the document window. The table or selected cells are 
updated each time a change is made to a control in the dialog box. When unchecked (the 
default), the table or selected cells resumes the appearance it had before the dialog box was 
opened. Clicking Cancel while Preview is on also causes the table to revert to the state it had 
before opening the dialog.

Some conventions apply to multiple controls in the dialog boxes. For example, controls that 
allow users to enter numerical values perform error checking as soon as the text box loses 
focus. If the user has entered a value that is outside the acceptable range, an error message 
appears. The error message box points out the error and lists the acceptable values.

10.4 Cell Options 
dialog box

The Cell Options dialog box consists of four tabbed panels that can be opened directly from 
any command on the Table > Cell Options submenu. 

10.4.1 Formatting text in table cells
By default, the text typed in table cells has the same formatting as the table anchor. Users can 
modify any table text by selecting it or its container cell and adjusting values in the Character 
palette or Paragraph palettes. For more details on formatting cell contents (as opposed to the 
cell itself), see “Text selection versus cell selection” on page 8.
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But when it comes to formatting the placement and orientation of text within table cells, 
users need to turn to the Text panel of the Cell Options dialog box. The illustration below 
shows the default settings for each control; those controls that reflect the current selection 
show values for a new table created with default values.

Figure 15: The Text panel of the Cell Options dialog box

The Cell Insets group box are comparable to the text frame inset controls in the Text Frame 
Options dialog box. This group box includes the following controls:

Top: Specifies the top “margin” of a cell in which no text (or other cell content) can appear. 
The default is 0p4. The minimum and maximum acceptable values are 0 and 720p0, respec-
tively. If a value outside this range is specified, an error message appears as soon as that con-
trol loses focus. The message box points out the error and lists the acceptable values.

Bottom: Specifies the bottom “margin” of a cell in which no text (or other cell content) can 
appear. The default is 0p4. The minimum and maximum acceptable values are 0 and 720p0, 
respectively. If a value outside this range is specified, an error message appears as soon as that 
control loses focus. The message box points out the error and lists the acceptable values.

Left: Specifies the left “margin” of a cell in which no text (or other cell content) can appear. 
The default is 0p4. The minimum and maximum acceptable values are 0 and 720p0, respec-
tively. If a value outside this range is specified, an error message appears as soon as that con-
trol loses focus. The message box points out the error and lists the acceptable values.

Right: Specifies the right “margin” of a cell in which no text (or other cell content) can 
appear. The default is 0p4. The minimum and maximum acceptable values are 0 and 720p0, 
respectively. If a value outside this range is specified, an error message appears as soon as that 
control loses focus. The message box points out the error and lists the acceptable values.

The Vertical Justification group box includes two controls:

Align: Specifies how to arrange text within a cell. The available settings and their behavior 
are the same as the corresponding option in the Text Frame Options dialog box:

• Top (the default)

• Center

• Bottom
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• Justify

Paragraph Spacing Limit: Disabled unless Justify is chosen in the Align drop-down list, this 
control allows users to set a maximum amount of space that will be added between para-
graphs. Once this maximum is reached, InDesign adds space between lines as needed to fill 
the cell with text. The default is 0. Allowable values are from 0 to 720p0. If a value outside 
this range is specified, an error message appears as soon as that control loses focus. The mes-
sage box points out the error and lists the acceptable values.

The First Baseline group box has just two controls:

Offset drop-down list: Specifies the distance between the top inset of the cell and the base-
line of the first line of text characters. These options function the same the corresponding 
options in the Text Frame Options dialog box:

• Ascent (the default)

• Cap Height

• Leading

• EmBox Height (Japanese version only)

• x Height

• Fixed

Min. text box: When Ascent, Cap Height, x Height or Leading are selected in the Offset 
drop-down list, the value specified here indicates the minimum amount of space between 
the top inset of selected cells and the baseline of the first line of text characters. The default 
is 0. Allowable values are 0 to 720p0. If a value outside this range is specified, an error mes-
sage appears as soon as that control loses focus. The message box points out the error and 
lists the acceptable values.

The Clipping group box contains a single control for handling items too large for a cell:

Clip Contents to Cell: When checked, causes any text or inline graphics that otherwise 
extend beyond any cell edge to be clipped to the cell boundary. For related information, see 
“Content fitting” on page 5.

The Text Rotation group box features a single drop-down list for determining the orientation 
of text in each cell:

Rotation: Allows users to specify one of several orientation options for text in selected cells. 
The available items in the drop-down list are as follows:

• 0° (the default)

• 90°

• 180°

• 270°

10.4.2 Formatting cell strokes and fills
The Strokes and Fills panel gives users finer control over the individual strokes of table cells 
and also provides controls for formatting cell fills. Note the following:

• The controls in this panel affect only the currently selected cells, as explained in “Scope 
of individual panels” on page 16.

• Most attributes controlled by this panel override those in other panels. See “Formatting 
priorities” on page 16.
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• Row strokes overwrite column strokes (for example, at the intersection of row and 
column strokes.)

The illustration below shows the default settings for each control; those settings that reflect 
the current selection show values for a new table created with default values.

Figure 16: The Strokes and Fills panel of the Table Options dialog box

The Cell Stroke group box includes the following controls:

Stroke-selection proxy: Allows the user to specify which strokes of a table cell will be 
affected by the remaining controls in this group box. As illustrated below, the appearance of 
the proxy depends on the selection when the user opens the dialog box.

Figure 17: Stroke selection proxy reflects the current selection.

By default, the proxy is shown with all relevant edges selected. Users can then click the top, 
bottom, left, or right edges of the proxy to deselect (or reselect) the corresponding outer 
edges of the current selection. Users can also click the interior vertical line or interior hori-

Default appearance with insertion point or single

Default appearance with two or more cells in a

cell selected (left) and after deselecting all edges
(right)

single column selected (left) and after deselecting
all edges (right)

Default appearance with two or more cells in a
single row selected (left) and after deselecting
all edges (right)

Default appearance with cells in multiple rows
and columns selected (left) and after deselecting
all edges (right)
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zontal line to select the corresponding interior horizontal strokes or vertical strokes of the 
current selection. The proxy represents selections using light blue lines (RGB 79, 153, 255) 
and hollow points at the end of each.

Figure 18: Examples of various proxy selection states

Note that if all the text in the selection is rotated, the greeked text in the proxy will run top 
to bottom, not left to right. If only part of the selection is rotated, the proxy does not change 
from the default of horizontal greeked text.

Users can also use any of these selection shortcuts:

• Click an unselected line to add to the current selection.

• Click a selected line to remove the line from the current selection.

• Double-click either interior line to select all interior (horizontal and vertical) lines.

• Double-click any outer edge to select the entire outer selection rectangle.

• Triple-click anywhere in the proxy to select all lines in the proxy.

Weight: Specifies the line weight for those parts of the current selection specified in the 
proxy. The default is 1 pt. The minimum value is 0 pt; the maximum is 800 pt. The incre-
ments displayed in the drop-down list are the same as for the Weight control in the Stroke 
palette. For more information, see the Stroke Palette user interface specification on the 
Adobe Common UI intranet site.

Type: Specifies the line style (for example, solid, etc.) for those parts of the current selection 
specified in the proxy. The default is Solid. 

Figure 19: The Type drop-down list

Color: Specifies the stroke color for those parts of the current selection specified in the proxy. 
The choices listed here are taken from the Swatches palette. This list is updated each time the 
dialog box is opened to include all colors and the same names displayed in the Swatches pal-
ette. The default is [Black].

Tint: Specifies the percentage of ink of the specified color applied to those parts of the cur-
rent selection specified in the proxy. The default is 100%. Possible values range from 0 to 100.

Overprint Stroke: When checked, causes the ink specified in the Color drop-down list to be 
applied over any underlying colors rather than knocking out those inks. In this situation, the 
fill ink goes under the stroke ink up to the center of the cell stroke. The center of cell strokes 
rests on the cell border. This control is unchecked (knocks out) by default. 

The Cell Fill group box includes the following controls:

Color: Specifies the fill color for currently selected cells. The choices listed here are taken 
from the Swatches palette. This list is updated each time the dialog box is opened to include 
all colors and the same names displayed in the Swatches palette. The default is [None].

http://interface.corp.adobe.com/guidelines/media/stroke-pal.pdf
http://interface.corp.adobe.com/guidelines/index.html
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Tint: Specifies the percentage of ink of the specified color applied to the fill of selected cells. 
The default is 100%. Possible values range from 0 to 100.

Overprint Fill: When checked, causes the ink specified in the Color drop-down list to be 
applied over any underlying colors rather than knocking out those inks. This control is 
unchecked (knocks out) by default.

10.4.3 Formatting row height and column width
The Rows and Columns panel provides controls for modifying the size of rows and columns. 
Unlike the panels discussed up to this point, the settings in this panel only affect rows or col-
umns intersected by the current selection (see “Scope of individual panels” on page 16). The 
illustration below shows the default settings for each control; those controls that reflect the 
current table or selection show values for a new table created with default values.

Figure 20: The Rows and Columns panel of the Table Options dialog box

Note: Text labels in this dialog box need to be sensitive to table orientation. For example, a 
rotated table (such as in a Japanese version) might need to read “Row Width” and “Column 
Height” unless a suitable translation can be found that accounts for both.

Row Height drop-down list: This control allows users to choose to make cells grow automat-
ically as text is added or to specify an exact height. In either case, however, cells will have a 
maximum height to prevent a cell from being taller than a single page. The choices for this 
control are:

• At Least: Constrains the row height to an amount no smaller than the value specified in 
the text box at the right. The row may be larger than this amount, however, as the row 
height will continue to grow automatically as the user adds text. This is the default 
choice.

• Exactly: Constrains the row height to exactly the amount specified in the Minimum 
text box. Changing the content of any cells in the row does not affect the row height. As 
a result, adding text to a cell specified with this setting may cause an overset text 
condition.
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Maximum value: Specifies the maximum height a row may grow to when At Least is selected 
in the neighboring drop-down list. The default is 50p. The minimum is 0p3; the maximum 
allowable value is 720p.

Column Width: Specifies the width of any columns intersected by the current selection. The 
default value is determined by the space between the container frame’s inset settings and the 
number of columns. The minimum is 0p3; the maximum allowable value is 720p. 

Settings in the Keep Options group box control how tables are positioned within and among 
their container text frames.

Start Row: The choices in this drop-down list let the user control the text frame or text col-
umn in which the row or rows intersected by the current selection fall. If any of these settings 
cause a conflict with the Keep with Next Row control, this option has priority. The choices 
are as follows:

• Anywhere (the default)

• In Next Text Column

• In Next Frame

• On Next Page

• On Next Odd Page

• On Next Even Page

Keep with Next Row: When checked, ensures that the row or rows intersected by the current 
selection currently selected are kept in the same text frame as the following row. It is 
unchecked by default.

10.4.4 Creating diagonal lines
The Diagonal Lines panel allows users to divide cells diagonally into two parts (or four parts 
if the fourth option is selected). Using these controls will draw one or two diagonal lines in 
the current cell (if only an insertion point is present) or in selected cells only (if one or more 
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cells are selected). The illustration below shows the default settings for each control; those 
settings that reflect the current selection show values for a new table created with default val-
ues.

Figure 21: The Diagonal Lines panel of the Cell Options dialog box

The Diagonal Lines panel includes the following controls:

Draw in Front: When selected, the diagonal line appears in front of cell content. This is the 
default.

Draw in Back: When selected, the diagonal line appears in back of cell content.

Line types: These buttons let the user choose from having no diagonal line, having a line 
connect the top left and bottom right corners, connect the top right and bottom left corners, 
or both. The first (no line) is the default.

Weight: Specifies the line weight for the diagonal line(s). The default is 1 pt. The minimum 
value is 0 pt; the maximum is 800 pt. The increments displayed in the drop-down list are the 
same as for the Weight control in the Stroke palette. For more information, see the Stroke 
Palette user interface specification on the Adobe Common UI intranet site.

Type: Specifies the line style (for example, solid) for the diagonal line(s). The default is Solid. 
This drop-down list is the same as the one shown in Figure 19 on page 21.

Color: Specifies the color for the diagonal line(s). The choices listed here are taken from the 
Swatches palette. This list is updated each time the dialog box is opened to include all colors 
and the same names displayed in the Swatches palette. The default is [Black].

Tint: Specifies the percentage of ink of the specified color applied to the diagonal line(s). The 
default is 100%. Possible values range from 0 to 100.

Overprint Stroke: When checked, causes the ink specified in the Color drop-down list to be 
applied over any underlying colors rather than knocking out those inks. This control is 
unchecked (knocks out) by default.

10.5 Table Options 
dialog box

The Table Options dialog box consists of four tabbed panels that can be opened directly from 
any command on the Table > Table Options submenu. 

http://interface.corp.adobe.com/guidelines/media/stroke-pal.pdf
http://interface.corp.adobe.com/guidelines/media/stroke-pal.pdf
http://interface.corp.adobe.com/guidelines/index.html
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10.5.1 Apply formatting to an entire table
The Table Setup panel provides controls for modifying the size of an existing table and apply-
ing a global fill and a stroke around the table perimeter. The settings affect all rows or col-
umns, even if only one cell is selected (or a cell has a text insertion point). The illustration 
below shows the default settings for each control; those controls that reflect the current table 
show values for a new table created with default values.

Figure 22: The Table Setup panel of the Table Options dialog box

The Table Dimensions group box lets users add rows or columns to or remove rows or col-
umns from the current table.

Rows: By default, this text box displays the number of rows in the current table. Conse-
quently, the minimum value for this control is the minimum number of allowable rows in a 
table (namely, 1). The maximum value for this control is 10,000. Increasing this number 
adds rows to the bottom of the table; decreasing deletes rows (and their contents) from the 
bottom of the table. An alert appears before rows are deleted.

The cells in newly added rows have the same formatting (fills, strokes, text, and so on) as the 
cells in the bottom row of the table at the time the dialog is opened.

Columns: By default, this text box displays the number of columns in the current table. Con-
sequently, the minimum value for this control is the minimum number of allowable columns 
in a table (namely, 1). The maximum value for this control is 100. Increasing this number 
adds columns to the right side of the table; decreasing deletes columns (and their contents) 
from the right side of the table. An alert appears before columns are deleted.

The cells in newly added columns have the same formatting (fills, strokes, text, and so on) as 
the rightmost column of the table at the time the dialog is opened.

The Table Border group box allows the user to apply a stroke around the table’s outside edge. 
If the table breaks across multiple frames, the border will lie along the top, left, and right 
edges for the first frame containing the table; along the left and right sides for intermediate 
frames; and along the left, right, and bottom sides for the final frame containing the table. 
For information on related controls, see “Formatting cell strokes and fills” on page 19. Note 
that table border settings override alternating stroke formatting, but cell stroke formatting 
overrides both of these (see “Formatting priorities” on page 16).
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Weight: Specifies the line weight for the table border. The default is 1 pt. The minimum 
value is 0 pt; the maximum is 800 pt. The increments displayed in the drop-down list are the 
same as for the Weight control in the Stroke palette. For more information, see the Stroke 
Palette user interface specification on the Adobe Common UI intranet site.

Type: Specifies the line style (Thick-Thin, Solid, etc) for the table border. The default is 
Solid. This drop-down list is the same as the one shown in Figure 19 on page 21.

Color: Specifies the color of the table border. The choices listed here are taken from the 
Swatches palette. This list is updated each time the dialog box is opened to include all colors 
and the same names displayed in the Swatches palette. The default is [Black].

Tint: Specifies the percentage of ink of the specified color applied to the table border. The 
default is 100%. Possible values range from 0 to 100.

Overprint: When checked, causes the ink specified in the Color drop-down list to be applied 
over any underlying colors rather than knocking out those inks. This control is unchecked 
(knocks out) by default.

Preserve Local Formatting: When checked, causes the settings in this group box to have no 
effect on any cells formatted using other formatting methods (Cell Options dialog box, 
Stroke palette, Color palette, etc).

The Table Spacing group box lets users add space above and below a table to give users more 
control over vertical placement of a table. If a table anchor is in a paragraph by itself or is the 
first or last line of a paragraph, these values are added on to the paragraph’s Space Before or 
Space After values or both (depending on where the table occurs in a paragraph).

Space Before: Specifies how much space to add above the table’s top border. The default is 
0p4. This value does not affect the placement of a table row that falls at the top of a frame as 
a result of a table breaking across frames. Instead, it is applied only to the first row of the 
entire table. This setting has no effect on tables that appear at the top of a frame; in that case, 
the table acts as if the setting is 0. Acceptable values for this control are 0p to 720p.

Space After: Specifies how much space to add below the table’s bottom border. The default 
is -0p4. Acceptable values for this control are -108p to 720p.

10.5.2 Formatting alternating strokes and fills
The Row Strokes, Column Strokes, and Fills tabs let the user set up a pattern of fills and 
strokes to enhance readability or general pizzaz. The Fills panel only allows formatting of 
either rows or columns (not both), whereas the Row Strokes and Column Strokes panels let 
users apply alternating patterns to either rows or columns (respectively) or both. As noted 
earlier (“Scope of individual panels” on page 16), the controls in these panels affect the entire 
current table regardless of the current selection. If the table is split across multiple frames, 
the alternating pattern continues across all frames, rather than restarting at the beginning of 
each frame.

http://interface.corp.adobe.com/guidelines/media/stroke-pal.pdf
http://interface.corp.adobe.com/guidelines/media/stroke-pal.pdf
http://interface.corp.adobe.com/guidelines/index.html
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The illustrations in this section show the default settings for each control; those controls that 
reflect the current table attributes show values for a new table created with default values.

Figure 23: The Row Strokes panel of the Table Options dialog box

Figure 24: The Column Strokes panel of the Table Options dialog box



28 Tables Adobe Interface Spec

Adobe Confidential

Figure 25: The Fills panel of the Table Options dialog box

The Row Strokes, Column Strokes, and Fills panels use the following controls:

Alternating Pattern: Displays a list of common groupings of fills or strokes. Except for the 
“Custom” option, selecting an item from this list changes the values in the First and Next 
controls to the appropriate values, simplifying the process of setting up a repeating pattern. 
The options available in this list vary according to the current tabbed panel.

Figure 26: Left to right: The Alternating Pattern drop-down list in 
the Row Strokes, Column Strokes, and Fills panels, respectively

Specifically, the commands have the following effects:

• None (the default) sets both First and Next controls to 0. It also sets all the controls in 
the Alternating group box to their defaults and disables them.

• Every Other Row/Column sets both First and Next controls to 1.

• Every Second Row/Column sets both First and Next to 2.

• Every Third Row/Column sets both First and Next to 3.

• Custom Row/Column sets First to 1 and Next to 2. Users cab adjust the First and Next 
to other values if desired.

As noted below, if users select one of other options and then changes one of the values in First 
or Next, the Alternating Pattern control is automatically changed to Custom. In addition, if 
the user manually sets the First and Next controls to values that conform to one of the above 
patterns, the appropriate pattern name will automatically be selected in this control. For 
example, if the user sets First to 2 and Next to 2, Alternating Pattern becomes “Every Second 
Row” or “Every Second Column.”
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In addition, the static text following the First, Next, Skip First, and Skip Last controls in the 
Fills panel changes from “Rows” to “Columns” or vice-versa, depending on the Alternating 
Pattern choice.

First: Specifies how many consecutive rows or columns that will receive the formatting spec-
ified in the Weight, Type, Color, Tint, and Overprint controls immediately below. Allowable 
values are 0 to the number of rows or columns currently in the table. As explained in “Alter-
nating Pattern” above, the value displayed for this and the Next control may change when the 
user chooses an option from the Alternating Pattern drop-down list. If the user manually 
changes this number, the Alternating Pattern setting automatically changes to Custom 
Column/Row. This control is disabled if None is chosen in the Alternating Pattern drop-
down list.

Next: Specifies how many consecutive rows or columns that will receive the formatting spec-
ified in the Weight, Type, Color, Tint, and Overprint controls immediately below. Allowable 
values are 0 to the number of rows or columns currently in the table. As explained in “Alter-
nating Pattern” above, the value displayed for this and the First control may change when the 
user chooses an option from the Alternating Pattern drop-down list. If the user manually 
changes this number, the Alternating Pattern setting automatically changes to Custom 
Column/Row. This control is disabled if None is chosen in the Alternating Pattern drop-
down list. 

Weight: Specifies the line weight for all cell borders in the current group. The default is 1 pt. 
The minimum value is 0 pt; the maximum is 800 pt. The increments displayed in the drop-
down list are the same as for the Weight control in the Stroke palette. For more information, 
see the Stroke Palette user interface specification on the Adobe Common UI intranet site.

Type: Specifies the line style (Thick-Thin, Solid, etc) for all cell borders in the current group. 
The default is Solid. This drop-down list is the same as the one shown in Figure 19 on 
page 21.

Color: Specifies the color for all cell borders in the current group. The choices listed here are 
taken from the Swatches palette. This list is updated each time the dialog box is opened to 
include all colors and the same names displayed in the Swatches palette. The default is 
[Black].

Tint: Specifies the percentage of ink of the specified color applied to all cell borders in the 
current group. The default is 100%. Possible values range from 0 to 100.

Overprint Stroke: When checked, causes the ink specified in the Color drop-down list to be 
applied over any underlying colors rather than knocking out those inks. This control is 
unchecked (knocks out) by default.

Skip First: Specifies how many top rows or left columns to which the settings in this panel 
will not be applied. If a value outside this range is specified, an error message appears as soon 
as that control loses focus. The message box points out the error and lists the acceptable val-
ues. The default is 0.

Skip Last: Specifies how many bottom rows or right columns to which the settings in this 
panel will not be applied. If a value outside this range is specified, an error message appears 
as soon as that control loses focus. The message box points out the error and lists the accept-
able values. The default is 0.

The Stroke Group 1 and Stroke Group 2 group boxes let users format the first set of alternat-
ing strokes. Because each of these group boxes contain the same controls, they are enumer-
ated here only once each:

http://interface.corp.adobe.com/guidelines/media/stroke-pal.pdf
http://interface.corp.adobe.com/guidelines/index.html
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Preserve Local Formatting: When checked, causes the settings in this tabbed panel to have 
no effect on any cells formatted using other formatting methods (Cell Options dialog box, 
Stroke palette, Color palette, etc).

11.0 Table palette

The Table palette provides an alternate interface for users to modify the look of a table. 
Although the palette does not provide any controls that are not already found elsewhere in 
InDesign 2.0, the palette include the most commonly controls to speed the formatting of 
table appearance.

11.1 Appearance The palette is displayed by choosing Window > Table. By default, all options are visible; users 
can choose Hide Options from the palette menu to hide the bottom half. Upon doing so, the 
Hide Options command becomes “Show Options.”

Figure 27: The Table palette in default mode (top) and with options hidden (bottom)

11.2 Palette menu The table palette menu includes the following commands:

Number of rows

Row height

Number of columns

Column width

Text alignment

Top and bottom
cell insets

Text rotation

Left and right
cell insets

Show / Hide Options

Table Options
Cell Options
Insert
Delete

Merge Cells
Split Cell Horizontally
Split Cell Vertically

Distribute Rows Evenly
Distribute Columns Evenly
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Show / Hide Options: As explained in the previous section, this command toggles the visi-
bility of the bottom section of the palette. By default the entire palette is visible and the com-
mand reads “Hide Options.” When chosen, it changes to read “Show Options.”

Table Options: Displays the same submenu as the Table > Table Options command in the 
main menu bar. See “Table Options” on page 33.

Cell Options: Displays the same submenu as the Table > Cell Options command in the main 
menu bar. See “Cell Options” on page 33.

Insert: Displays the same submenu as the Table > Insert command in the main menu bar. 
See “Insert” on page 33.

Delete: Displays the same submenu as the Table > Delete command in the main menu bar. 
See “Delete” on page 34.

Merge Cells: Performs the same function as the Table > Merge Cells command in the main 
menu bar. See “Merge Cells” on page 34.

Split Cell Horizontally: Performs the same function as the Table > Split Cell Horizontally 
command in the main menu bar. See “Split Cell Horizontally” on page 34.

Split Cell Vertically: Performs the same function as the Table > Split Cell Vertically com-
mand in the main menu bar. See “Split Cell Vertically” on page 35.

Distribute Rows Evenly: Performs the same function as the Table > Distribute Rows Evenly 
command in the main menu bar. See “Distribute Rows Evenly” on page 35.

Distribute Columns Evenly: Performs the same function as the Table > Distribute Columns 
Evenly command in the main menu bar. See “Distribute Columns Evenly” on page 35.

11.3 Tool tips and 
functions

The Table palette includes the controls listed in the following table. These are discussed in 
full in the “Modifying tables using commands and gestures” on page 12.

Icon Tool tip Function

Number of Rows See “Rows” on page 25.

Number of Columns See “Columns” on page 25.

Row Height See “Row Height drop-down list” on page 22.

Column Width See “Column Width” on page 23.

Align Top

See “Align” on page 18.

Align Center

Align Bottom

Align Justify

Rotate 0°

Rotate 90°

Rotate 180°

Rotate 270°
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12.0 Table menu

The Table menu on the main menu bar provides most of the commands for creating and 
editing tables.

Insert Table: Displays the Insert Table dialog box for specifying the attributes of a new table 
(see Figure 1 on page 3). This command is unavailable if there is no active text insertion 
point in the current document. Consequently, users cannot choose this command with no 
insertion point in order to set the default number of rows and columns as might be expected 
given the usual convention for setting defaults in InDesign. If a text selection is present when 
the user chooses this command, any table created as a result will replace the selected text. For 
more on table creation, “Creating tables” on page 3.

Convert Text to Table: Available only when one or more characters in a text frame are 
selected, this command creates a new table in the current text frame and places the selected 
text in the table cells. In making the conversion, tab characters are treated as column bound-
aries and carriage returns are treated as row boundaries. If text on a path is converted to a 
table, the table will not appear on the path, but will flow into the next threaded text frame (if 
one exists) or becomes overset text.

Convert Table to Text: Available only when a table has an insertion point or text selection or 
one or more cells are selected, this command converts the entire table into tab-delimited text 
(with carriage returns separating rows). Conversion of only part of a table is not supported. 
Note that if a user converts a table to text and then back to a table, the result won’t be the 
same as the original table, since formatting and effects like split and merged cells would be 
lost.

Top Inset Spacing

See the discussion of the Cell Insets group box on page 18.
Bottom Inset Spacing

Left Inset Spacing

Right Inset Spacing

Icon Tool tip Function

Insert Table...
Convert Text to Table
Convert Table to Text

Table Options
Cell Options

Insert
Delete
Select

Merge Cells
Split Cells Horizontally
Split Cells Vertically

Distribute Rows Evenly
Distribute Columns Evenly

Go to Row...
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Table Options: Displays the following submenu for adjusting table attributes and format-
ting. These commands are unavailable if there is no active text insertion point in an existing 
table or if there is no active table selection. Consequently, users cannot choose these com-
mand with no insertion point present to set defaults as is the norm with other InDesign com-
mands. For more information, see “Modifying tables using Table Options and Cell Options 
dialog boxes” on page 16.

• Table Setup: Displays the Table Setup panel of the Table Options dialog box. For more 
information, see “Apply formatting to an entire table” on page 25.

• Alternating Row Strokes: Displays the Row Strokes panel of the Table Options dialog 
box. For more information, see “Formatting alternating strokes and fills” on page 26.

• Alternating Column Strokes: Displays the Column Strokes panel of the Table Options 
dialog box. For more information, see “Formatting alternating strokes and fills” on 
page 26.

• Alternating Fills: Displays the Fills panel of the Table Options dialog box. For more 
information, see “Formatting alternating strokes and fills” on page 26.

Cell Options: Displays the following submenu for adjusting table attributes and formatting. 
These commands are unavailable if there is no active text insertion point in an existing table 
or if there is no active table selection. Consequently, users cannot choose these command 
with no insertion point present to set defaults as is the norm with other InDesign com-
mands. For more information, see “Modifying tables using Table Options and Cell Options 
dialog boxes” on page 16.

• Text: Displays the Text panel of the Cell Options dialog box. For more information, see 
“Formatting text in table cells” on page 17.

• Strokes and Fills: Displays the Strokes and Fills panel of the Cell Options dialog box. 
For more information, see “Formatting cell strokes and fills” on page 19.

• Rows and Columns: Displays the Rows and Columns panel of the Cell Options dialog 
box. For more information, see “Formatting row height and column width” on 
page 22.

• Diagonal Lines: Displays the Diagonal Lines panel of the Cell Options dialog box. For 
more information, see “Creating diagonal lines” on page 23.

Insert: Displays the following submenu with commands for inserting new rows or columns. 
Each of these commands displays a dialog box. For more information, see “Inserting a new 
row” on page 14 and “Inserting a new column” on page 15.

Table Setup...
Alternating Row Strokes...
Alternating Column Strokes...
Alternating Fills...

Text...
Strokes and Fills...
Rows and Columns...
Diagonal Lines...

Row...
Column...
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Delete: Displays the following submenu with commands for deleting the listed table ele-
ments. For more information, see “Deletion” on page 16.

The commands on this submenu exhibit the following attributes:

• All the commands are disabled until at least one cell in a table has been selected or until 
a text insertion point exists in a table cell.

• The Row command deletes all rows intersecting the current selection or a single row 
containing the insertion point.

• The Column command deletes all columns intersecting the current selection or a single 
column containing the insertion point.

• The Table command deletes not only the portion of the table found in the current 
frame but the entire table in all threaded frames.

Select: Displays the following submenu with commands for selecting the listed table ele-
ments.

The commands on this submenu exhibit the following attributes:

• All the commands are disabled until at least one cell in a table has been selected or until 
a text insertion point exists in a table cell.

• The Cell command is only enabled when no cells are selected but a text insertion point 
exists in a table cell. Invoking the command selects that cell with the type tool still 
active.

• The Row command selects all rows intersecting the current selection or a single row 
containing the insertion point.

• The Column command selects all columns intersecting the current selection or a single 
column containing the insertion point.

• The Table command selects all cells in a table containing a selection or insertion point.

For more on table selection, see “Selection issues” on page 7.

Merge Cells: Combines two or more contiguous selected cells into one cell. The selection 
can contain cells in more than one row or more than one column, or both. This command 
is disabled unless two or more cells are selected. When invoked, the content of the original 
selected cells are combined into the resulting single cell, separated by carriage returns.

Split Cell Horizontally: Divides one or more selected cells or a cell containing an insertion 
point into a pair of cells of equal size using a horizontal divider line. The content of the orig-
inal cell is placed in the top left cell of the selection. The style and formatting of the top left 
cell of the selection is maintained and applied to all text moved into that cell. A carriage 
return is placed at the end of the original content of each cell. Consequently, if the selected 
cell is empty, a carriage return will represent that cell in the merged result. This command is 
disabled if more than one cell is selected.

Row
Column
Table

Cell
Row
Column
Table
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Split Cell Vertically: Divides one or more selected cells or a cell containing an insertion point 
into a pair of cells of equal size using a vertical divider line. The content of the original cell is 
placed in the left cell of each pair. This command is disabled if more than one cell is selected.

Distribute Rows Evenly: Disabled unless cells in more than one row are selected, this com-
mand makes all rows having at least one cell selected the same height (the average of all rows 
in the selection). This is accomplished by setting the “Row Height drop-down list” setting to 
Exactly and entering the averaged value in the box to the right in the Rows and Columns 
panel of the Table Options dialog box. See “Formatting row height and column width” on 
page 22. 

Distribute Columns Evenly: Disabled unless cells in more than one column are selected, this 
command makes all columns having at least one cell selected the same width (the average of 
all rows in the selection).

Go to Row: Displays the Go to Row dialog box (see Figure 4 on page 7), which lets users type 
in a desired row number and click OK to navigate to the first cell in that row. If the table con-
tains a text selection or insertion point or a cell selection of no more than one row, the dialog 
may display the number of the current row when it is first opened. The dialog box only nav-
igates within the currently selected table, not a parent table (in the case of one table nested 
inside another).This command is disabled until there is a text insertion point, text selection, 
or cell selection in an existing table.

13.0 Context menus

The context menu for tables takes two forms, depending on whether there is a text selection 
or text insertion point on the one hand or one or more selected cells on the other. For more 
information on submenus associated with the tables feature as well as submenus in InDesign 
2.0 generally, see the InDesign 2.0 Context Menus specification on the Annapurna UI intra-
net site.

13.1 Context menu for 
text selection or 
insertion point

The following menu is added on to the existing text context menu. That is, it appears when 
a user context-clicks a text insertion point or text selection in a table cell. The top part of the 
menu (indicated by ... in the illustration) has the same commands as found on the context 
menu for a text insertion point or text selection outside of a table.

For a discussion of the commands and submenus in this context menu, see the correspond-
ing menu items discussed in “Table menu” on page 32.

...

Insert
Delete
Select

http://indesign-projects.sea.adobe.com/anna/UI/pdf/ID2_context_menus_v9.pdf
http://indesign-projects.sea.adobe.com/anna/ui/index.html
http://indesign-projects.sea.adobe.com/anna/ui/index.html
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13.2 Context menu for 
cell selection

The following menu appears when one or more selected cells in a table are context-clicked. 
Note that one or more of these commands may not appear on the menu depending on the 
context. (For example, the merge and split commands will never appear simultaneously).

The Rotate submenu has the following commands:

Each of these commands rotates the text (or insertion point) in the current cell the amount 
specified in the command.

For a discussion of the remaining commands and submenus in this menu, see the corre-
sponding items discussed in “Table menu” on page 32.

14.0 Pointers/cursors

The table feature includes a number of different pointers to help users anticipate the results 
of clicking and dragging in various parts of a table. Note that in the case of rotated tables (as 
in the Japanese version), these pointers may be rotated as well.

Rotate

Table Options
Cell Options

Insert
Delete
Select

Merge Cells
Split Cells Horizontally
Split Cells Vertically

Distribute Rows Evenly
Distribute Columns Evenly

0° 
90°
180°
270°

Shape Name Use

Row Selection
Appears when mousing over the left edge of a table (or just inside the table 
boundary). Indicates that clicking will result in a selected row.

Column 
Selection

Appears when mousing over the top edge of a table (or just inside the table 
boundary). Indicates that clicking will result in a selected column.

Table Selection
Appears when mousing over the top left corner of a table (or just inside the 
table boundary). Indicates that clicking will select the entire table.

Resize, Add, or 
Remove 
Vertically

Appears when mousing over row borders or the bottom a table. Indicates 
that dragging will resize the table or row or add or remove rows depending 
on what key (or no key) is held down. 

Resize, Add, or 
Remove 
Horizontally

Appears when mousing over the column borders or the right edge of a table. 
Indicates that dragging will resize the table or column or add or remove 
columns, depending on what key (or no key) is held down.
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15.0 Commands, keystrokes, and gestures

InDesign employs numerous shortcuts, mouse gestures, and commands to simplify table 
tasks.

15.1 Table commands The table features uses the menu commands summarized in the following table. Note that 
issues relating to cutting and pasting are covered in another specification, Table Cut/Copy 
and Paste, by Lisa Andrews, available in the Engineering: Specs and Documentation section 
of the Annapurna intranet site.

Resize, Add, or 
Remove 
Diagonally

Appears when mousing over the corner resize handles of a selected table. 
Indicates that clicking and dragging will resize the table in the direction the 
user drags. 

Text 
Appears when mousing over a cell in a table. Indicates that clicking will insert 
the focus into the cell. Also displays when clicking and dragging through cell 
contents. Indicates that dragging outside cell will select entire cell. 

Shape Name Use

Action Command

Create a table Table > Insert Table
Make a table from selected text Table > Convert Text to Table
Change table into tab-delimited text Table > Convert Table to Text

Set table size, border, and spacing
Table > Table Options > Table Setup

Context click > Table Options > Table Setup

Add alternating horizontal strokes to a table
Table > Table Options > Alternating Row Strokes

Context click > Table Options > Alternating Row Strokes

Add alternating vertical strokes to a table
Table > Table Options > Alternating Column Strokes

Context click > Table Options > Alternating Column Strokes

Add alternating fills to table rows or 
columns

Table > Table Options > Alternating Fills

Context click > Table Options > Alternating Fills

Set position of text in selected cells
Table > Cell Options > Text

Context click > Cell Options > Text

Set stroke and fill appearance for selected 
cells

Table > Cell Options > Strokes and Fills

Context click > Cell Options > Strokes and Fills

Set row height and column width for 
selected cells

Table > Cell Options > Rows and Columns

Context click > Cell Options > Rows and Columns

Add and format diagonal lines in selected 
cells

Table > Cell Options > Diagonal Lines

Context click > Cell Options > Diagonal Lines

Rotate text in current cell(s)

Context click > Rotate 0º
Context click > Rotate 90º
Context click > Rotate 180º
Context click > Rotate 270º

Add a row to a table
Table > Insert > Row

Context click > Insert > Row

Add a column to a table
Table > Insert > Column

Context click > Insert > Column

Delete current row
Table > Delete > Row

Context click > Delete > Row

http://indesign-projects.sea.adobe.com/Anna/Documents/Functional%20Specifications/Tables/091200_TablesCCP8x11_v48.pdf
http://indesign-projects.sea.adobe.com/Anna/Documents/Functional%20Specifications/Tables/091200_TablesCCP8x11_v48.pdf
http://indesign-projects.sea.adobe.com/anna/Documents/docsListing.asp?Dir=Functional%20Specifications&Home=Functional%20Specifications&Desc=FUNCTIONAL%20SPEC%20DOCUMENTS&BaseInc=Features/SpecReviewers.htm&Detailed=Functional%20Specifications
http://indesign-projects.sea.adobe.com/anna
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15.2 Gestures and 
keystrokes for table 
navigation

The following behaviors are useful for moving the insertion point or selection highlight 
within a table. For related information, see “Cell and row navigation” on page 6.

Delete current column
Table > Delete > Column

Context click > Delete > Column

Delete current table
Table > Delete > Table

Context click > Delete > Table

Select cell with insertion point
Table > Select > Cell

Context click > Select > Cell

Select entire current row
Table > Select > Row

Context click > Select > Row

Select entire current column
Table > Select > Column

Context click > Select > Column

Select entire table
Table > Select > Table

Context click > Select > Table
Select text in cell with insertion point Edit > Select All
Select all cells in table with cell selection Edit > Select All
Deselect all text and cells in table Edit > Deselect All

Combine selected cells
Table > Merge Cells

Context click > Merge Cells

Add horizontal divider to current cell
Table > Split Cell Horizontally

Context click > Split Cell Horizontally

Add vertical divider to current cell
Table > Split Cell Vertically

Context click > Split Cell Vertically

Set current rows to equal height
Table > Redistribute Rows

Context click > Redistribute Rows

Set current columns to equal width
Table > Redistribute Columns

Context click > Redistribute Columns
Selects the cells in the designated row Table > Go to Row
Display or hide Table palette Window > Table

Action Command

Action Keystroke or gesture

With insertion point at last position in cell, move one cell to right; for far right 
column, move to far left column (except when pressing Shift)

Right arrow

With insertion point at first position in cell, move one cell to left; for far left 
column, move to far right column (except when pressing Shift)

Left arrow

With insertion point at last position in cell, move one cell down; for bottom row, 
move to top row (except when pressing Shift)

Down arrow

With insertion point at first position in cell, move one cell up; for top row, move 
to bottom row (except when pressing Shift)

Up arrow

With insertion point in bottom line of text in cell, move to last position in cell Down arrow
With insertion point in top line of text in cell, move to first position in cell Up arrow
With insertion point in first position of top left cell, move insertion point outside 
of table

Left arrow

Move insertion point or text selection highlight to next cell (left to right, top to 
bottom)

Tab

Move insertion point or text selection highlight to previous cell (right to left, 
bottom to top)

Shift+Tab
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15.3 Gestures and 
keystrokes for table 
selection

The following behaviors are useful for moving the insertion point or selection highlight 
within a table. Note that drag-selecting is not covered since it behaves much the same as 
drag-selecting text except that a selection of table cells always has a rectangular shape. Note 
too that additional selection options are covered in “Table commands” on page 37. For addi-
tional information, see “Selection issues” on page 7.

15.4 Gestures and 
keystrokes for table 
resizing

The following table summarizes the various methods for drag-resizing a table and the sup-
ported modifier keys.

With text selection or insertion point in top cell, move insertion point or 
selection highlight to bottom right cell

Shift+Tab 

With text selection or insertion point in bottom right cell, add a row to bottom of 
table

Tab

Action Keystroke or gesture

Action Keystroke or gesture

Select a single column Click top edge of desired column
Select a single row Click left edge of desired row

Select a range of columns
Click top edge of column; then Shift-click top edge 
of another column

Select a range of rows
Click left edge of row; then Shift-click left edge of 
another row

Select all cells in table Click top left corner of table
With insertion point in final position in cell, select 
entire cell

Shift+Right Arrow

With insertion point in beginning position in cell, 
select entire cell

Shift+Left Arrow

Having selected a cell, change back to cell content 
selection

Shift+arrow key in opposite direction (toward 
starting point)

Extend selection rectangle left, right, up, or down Shift+arrow key away from starting point
Shrink selection rectangle left, right, up, or down Shift+arrow key in reverse direction

No modifier key Shift Alt

Row 
edge

Resizes row above pointer 
(overall table height 
change as a result)

Resizes two rows 
on either side of 
edge

Dragging down adds one or more rows with 
the same dimensions as the row abovea; 
dragging up has no effect

a. This only applies to rows having a height setting of At Least; for a height setting of Exactly, the new 
row will be the height of the distance dragged as long as it is no larger than the above row.

Column 
edge

Resizes column to left of 
pointer (over-all table 
width changes as a result)

Resizes two 
columns on either 
side of edge

Dragging right adds one or more columns 
with the same dimensions as the column to 
the left; dragging left has no effect

Bottom 
edge

Resizes bottom row
Resizes all rows 
proportionally

Dragging down adds one or more rows with 
the same dimensions as the row above; 
dragging up deletes one or more rows

Right 
edge

Resizes right column
Resizes all 
columns 
proportionally 

Dragging right adds one or more columns 
with the same dimensions as the column to 
the left; dragging left deletes one or more 
columns

Bottom 
right 
corner

Resizes entire table

Resizes entire 
table, 
maintaining 
original aspect 
ratio

Dragging down and/or right adds rows and/
or columns with the same dimensions as 
row above or column to the left; dragging 
up and/or left deletes rows and/or columns
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15.5 Other gestures 
and keystrokes

The tables feature includes several mouse and keyboard shortcuts. These are documented in 
the keyboard shortcut spread sheet on the Annapurna intranet site. For additional shortcuts, 
see “Click-selecting using modifier keys” on page 10 and “Gestures and keystrokes for table 
resizing” on page 39.

16.0 Interaction with other features

The tables feature naturally intersects with a great many other features.

16.1 Stroke palette When one or more table cells is selected, the Stroke palette assumes a new appearance that 
includes the stroke selection proxy found in the Strokes and Fills panel of the Table Options 
dialog box. (See “Stroke-selection proxy” on page 20.) A larger version of the proxy can be 
seen in the palette by choosing Show Options from the palette menu. After using these con-
trols to select one or more cell segments, users can then use the other controls in the Stroke 
palette to format the selected strokes.

Figure 28: When all or part of a table is selected or has an insertion point, the Stroke palette 
assumes a new default look (left) and still another look when all options are showing (right)

The following behaviors apply to this palette:

• The proxy in the Stroke palette uses the same mouse shortcuts as the proxy in the 
Strokes and Fills panel of the Table Options dialog box. See “Commands, keystrokes, 
and gestures” on page 37.

• If the table is selected like an inline graphic—for example, when text before or after is 
selected including the table anchor—the Stroke palette does not have this special table 
mode, but assumes its normal appearance.

• If the active table contains only an insertion point or a text selection, the Stroke palette 
only affects any text typed; it has no effect on the current cell.

16.2 Tabs palette The tabs palette lets users define and refine the behavior of tab stops in text. The main inter-
face for doing this is the Tabs palette.
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The tab ruler will behave similarly in tables as in regular text. The difference is that each cell 
behaves like a separate story. When a cell or column of cells are selected and the tab ruler dis-
played (by choosing Type > Tabs), the tab ruler will become available with the active area 
marked in white. The active area represents the width of the text area (space between insets) 
of a cell or column.

Figure 29: The active area of the tab ruler represents the width of the cell(s) to which the 
settings will be applied.

If the user selects an entire column of a multi-page table, any changes to tab settings are 
applied only to the selected column.

By default, active area of the tab ruler snaps to the top left cell of a selection (not the top of 
the containing frame). (If a table is rotated, the ruler is still aligned with the top left cell of 
the table after rotation.) If columns of different widths are selected, the active area is the same 
width as the leftmost cell. If a column spanning multiple pages is selected, the tab ruler snaps 
to the first portion of the column on the active spread. As with text frames, if the tab ruler is 
moved, it can be snapped back into default position by clicking the magnet icon.

If the selection includes cells with different tab settings, those tabs are shown in gray in the 
Tab ruler.

Figure 30: Tab stops appear gray when cells having different tab settings are selected.

In all other respects, the interface for the tab ruler and setting tab stops is the same as it is for 
text not found in tables.

16.3 Find/Change When users choose the Edit > Find/Change command, InDesign searches through tables in 
found in the current story if Story is chosen in the Search drop-down list, or through any 
tables (or portions of tables) following the current insertion point in the current story if To 

Indent markers

Tab stop
Tab ruler

Active Cell

Ruler

Active column

Magnet
icon

Tab stops

Active column
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End of Story is chosen in the Search drop-down list. If Document or All Documents is 
selected in the Search drop-down list, all tables in the current document or all open docu-
ments, respectively, are searched.

If some text or one or more cells are selected when the dialog box is opened, the Search drop-
down list defaults to Selection and only the selected text or cell(s) are included in the search.

The search command proceeds through tables in this order: left to right, top to bottom.

Note that there is no metacharacter available in the Find/Change dialog box that would allow 
users to search for a table.

16.4 Spelling When users choose the Edit > Check Spelling command, InDesign checks the spelling of text 
in tables in found in the current story if Story is chosen in the Search drop-down list, or to 
the text in any tables (or portions of tables) following the current insertion point in the cur-
rent story if To End of Story is chosen in the Search drop-down list. If Document or All Doc-
uments is selected in the Search drop-down list, all tables in the current document or all open 
documents, respectively, are spell checked.

If some text or one or more cells are selected when the dialog box is opened, the Search drop-
down list defaults to Selection and only the selected text or cell(s) are included in the spell 
check.

The Check Spelling command proceeds through tables in this order: left to right, top to 
bottom.

16.5 Create Outlines Users can convert the text in tables to vector outlines using the Type > Create Outlines. The 
command works on non-overset table text in the following situations:

• Selected text in a table cell

• Text in one or more selected table cells

• Table text in a frame selected by a selection tool

• Table text in a table in a selected run of text (i.e., the table anchor is part of a selection 
but table cells themselves are not selected per se)

When text in cells is converted to outlines, the text in each cell is replaced with an inline 
graphic. If the user holds down Alt while converting table text, the text is converted to an 
independent (not inline) graphic.

16.6 Text wrap If a table abuts a text-wrap boundary, it behaves like an inline graphic. That is, the entire table 
will move to accommodate the text-wrap boundary. If there is not enough space next to the 
boundary to accommodate the width of the table, the entire table will move down or into the 
next threaded frame (one row at a time) until it either finds enough space in the text frame 
to accommodate its entire width or until it is beyond the test-wrap boundary.

16.7 Toolbox The toolbox includes a new control for designating whether formatting affects the fill and 
stroke of text in a cell or the fill and stroke of the cell itself. See “Text selection versus cell 
selection” on page 8. Note that this control is not limited to table selection, but works for text 
frames as well.
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16.8 Gradients in 
tables

For a discussion of gradients in tables, see the “Interaction with tables” section of the InDe-
sign Gradient specification. This document can be found on the InDesign 2.0 User Interface 
intranet site.

16.9 Eyedropper tool For information on using the eyedropper tool with table formatting, see the “Interaction 
with tables” section of the Eyedropper Tool in InDesign specification. This document can be 
found on the InDesign 2.0 User Interface intranet site.

16.10 Other palettes As discussed earlier, users can format the text in any selected cells by using the normal text 
formatting tools such as the Character and Paragraph palettes, or by setting the text or object 
control in the toolbox to text mode and then using various color controls to change the text’s 
fill and/or stroke (see “Text selection versus cell selection” on page 8). Similarly, users want-
ing simply to format the fill and stroke of selected cells can use the toolbox to invoke con-
tainer mode and then use the normal tools for modifying these elements, such as the Stroke, 
Swatches, and Color palettes. For other table formatting options, see “Modifying tables using 
commands and gestures” on page 12.

17.0 Documentation issues

User Education may want to address the following issues in the user documentation:

17.1 Nuances of Alt-
dragging

When Alt-dragging to add rows or columns, the user must press the mouse button down 
before pressing the Alt key. Otherwise, pressing Alt alone will activate the hand tool.

17.2 Losing tables in 
overset conditions

It is possible for users to make a table so large it cannot fit in any frame. For example, if the 
user has created a table that is threaded across several frames, selects the entire table, and 
applies the Keep with Next Row option (choose Tables > Cell Options > Rows and Col-
umns), the entire table could disappear into an overset condition. If the table is big enough, 
it may be impossible to create a frame big enough to see the table. If user acts immediately 
to change the formatting, the problem can be corrected because the table is still selected, even 
in this overset condition. But if the user clicks somewhere else, the selection is lost and can-
not be restored. At this point, the user can still correct the situation by choosing Edit > Undo, 
but depending on their subsequent behavior, even this may not work. It may be useful to 
warn users to avoid this behavior.

http://indesign-projects.sea.adobe.com/anna/ui/pdf/InDesign_gradients2.pdf
http://indesign-projects.sea.adobe.com/anna/ui/pdf/InDesign_gradients2.pdf
http://indesign-projects.sea.adobe.com/anna/ui/pdf/tools_id_eyedrop.pdf
http://indesign-projects.sea.adobe.com/anna/UI/index.html
http://indesign-projects.sea.adobe.com/anna/UI/index.html
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