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Scripting

1.0 Revision history 

2.0 User problem

Users who write scripts for InDesign need a convenient way to launch those scripts from 
within the application.

3.0 Summary of solution

Two new palettes address scripting needs. The primary tool is the Script palette, which pro-
vides a handy way to display available scripts and quickly launch them. To a certain extent, 
this palette also provides a way for managing the display of scripts by letting users organize 
them into a hierarchy of nested folders. A secondary tool, the Script Label palette, lets users 
quickly assign labels (“tags”) to page items. Users can then write scripts that refer to page 
items by their tag.

4.0 Conventions

This document uses the following keyboard equivalents: 

Context-click refers to the gesture on both platforms that displays a context menu. In Win-
dows, this is a right-click; in Mac OS, this is a Control-click.

Date Name Description of changes

15 June 2001 J. Aguirre First draft
18 June 2001 J. Aguirre Made corrections based on comments from P. Boctor
19 September 2001 J. Aguirre Broadened scope of specification to include the Script Tag palette.
6 November 2001 J. Aguirre Updated with new info and design cleanup

Key in Windows Key in MacOS

Alt Option
Ctrl Commanda

a. The Macintosh Control key is used in the Adobe user interface standards
only in the Control-click gesture to access context menus.

Enter Returnb

b. Also the Enter key found on the numeric keypad on both platforms.
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5.0 Related info

The following documents and resources are also available:

• An overview of scripting and scripting documentation:

http://www.adobe.com/products/indesign/scripting.html

• Scripting specifications:

http://cbass/Anna/Documents/docsListing.asp?Dir=Scripting+Docs/
Anna+Alpha+Scripting+Specs&Home=Scripting+Docs&Desc=SCRIPTING+DOCS
&Detailed=Scripting+Docs

• The InDesign scripting user to user forum:

http://www.adobeforums.com/cgi-bin/webx?13@57.GrReanOHaMM^1@.eea52bc

6.0 Script palette

The Script palette provides a simple, intuitive interface for launching scripts stored in the 
Scripts folder. Like most palettes, it can be displayed or hidden by choosing Window > 
Script. By default, the Script palette is grouped with the Script Label palette. 

Figure 1: The InDesign 2.0 Script palette

6.1 List contents The list area of the Script palette displays items that are stored in the Scripts folder, which is 
found in the folder in which the user installed InDesign. However, not every item in the 
Scripts folder appears in the list. Instead, only the following items appear:

SD: Are there other file types that 
appear in this list?

• Windows Script files (VBScript or JScript)

• Applescript files.

• Application or executable files.

• Folders.

Note that folders appear as headings with a folder icon and a disclosure triangle. Clicking the 
triangle displays or hides the scripts or folders within that folder. These contents appear as 
an indented list under the folder name.

http://cbass/Anna/Documents/docsListing.asp?Dir=Scripting+Docs/Anna+Alpha+Scripting+Specs&Home=Scripting+Docs&Desc=SCRIPTING+DOCS&Detailed=Scripting+Docs
http://www.adobe.com/products/indesign/scripting.html
http://www.adobeforums.com/cgi-bin/webx?13@57.GrReanOHaMM^1@.eea52bc
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The palette updates this list automatically each time the folder contents is changed. This list 
is always alphabetized.

6.2 List behaviors The Script palette has one main function, namely to launch the scripts or executable files that 
appear in the list. To do this, the user simply double-clicks the item in the Script palette. 
Double-clicking a folder item displays or hides the contents of the folder, just as if the disclo-
sure triangle had been clicked.

SD: QA to determine limit for 
tool-tip length.

In addition, the Script palette has the ability to display tool tips describing the script under 
the pointer. To enable this feature in text-based script files in Windows, the user types 
'DESCRIPTION: on the first line of the script text, followed by the text that should appear 
in the tool tip. The tool tip includes all text found in that paragraph. In Mac OS Applescript 
files, the user inserts the desired tool tip text in the Comments area. Tool tips can be up to 
32, 768 characters.

Figure 2: Users can added descriptive text to scripts
that appear as tool tips in the Script palette.

InDesign does not provide any features for adding, removing, renaming, or reordering items 
in the list. However, users can use the operating system’s file tools to accomplish this by add-
ing or removing items from the Scripts folder (or subfolders), or renaming items to change 
their order in the alphabetical list.

Similarly, users who want to disable items can remove them from the Scripts folder hierarchy 
or change their file type to one not supported by InDesign. The result is that these items will 
not appear in the list.

For more on palette behaviors, see “Commands, keystrokes, and gestures” on page 4.

6.3 Initialization, 
states, and defaults

By default, the Script palette is not visible. Like most palettes, users can display the palette by 
choosing Window > Script.

In its default state, it shows the sample scripts that are automatically installed with InDesign 
2.0 and found in the Scripts folder as explained above. The default size shows four scripts, 
but users can resize the palette or use the scroll bar to see other items in the list.
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6.4 Pointers/cursors The Script palette uses the following pointers.

6.5 Commands, 
keystrokes, and 
gestures

The Script palette uses the following commands and keyboard shortcuts.

7.0 Script Label palette

The Script Label palette provides a simple way to label page items. These labels can then be 
referred to in by scripts to manipulate those items. Although scripting commands allow 
users to assign tags to page items from within a script, the Script Label palette simplifies the 
process. Like most palettes, the Script Label palette can be displayed or hidden by choosing 
Window > Script. As noted earlier, the Script Label palette is grouped with the Script palette 
by default.

Figure 3: The InDesign 2.0 Script Label palette

7.1 Palette attributes The Script Label palette has the following behaviors:

• This palette is not installed by default. Users must install it from the InDesign 2.0 
installer CD or from a Web download just as they would install any plug-in.

• The Script Label palette cannot be resized.

7.2 Palette behaviors The Script Label palette has the following behaviors:

• To assign a tag to one or more page items, the user selects the item(s) using any tool 
that leaves the item selected (i.e., showing selection handles). The user then types the 
desired tag into the text box of the Script Label palette. If more than one object was 
selected, the same tag is applied to each selected object.

• To edit an existing tag, the user selects the item(s) and edits the text in the Script Label 
text box.

Shape Name Use

Selection Indicates that clicking will select or otherwise prepare for further action.

[System 
specific]

Busy Displays the system hourglass or watch pointer when a script is being executed.

Action Command or shortcut

Open the Script palette Window > Script
Launch a script Double-click script name

Toggle display of folder 
contents

Click disclosure triangle
Double-click folder name

Cancel a script in progress Alt+Break (Windows) or Cmd+. (period) (Mac OS)
Add or remove items from 
the palette list

Not an InDesign feature. User must employ the operating system’s file tools 
to add or remove items from the Scripts folder.

Reorder items in the 
palette list

Not an InDesign feature. User must employ the operating system’s file tools 
to rename items to get the desired order, which is always alphabetical.
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• To remove an existing tag, the user selects the item(s), clicks in the text box to activate 
it, and deletes the text using the usual keyboard or context menu techniques.

• If multiple items having the same tag are selected, the tag name appears in the text box 
of the Script Label palette. If multiple items having different tags are selected, the text 
box appears empty. If all items are deselected, the text box appears empty. The text in 
the text box is updated each time the selection state of page items changes

• If no document is open, no object is selected, or if a text frame has a text selection or 
insertion point, any text typed into the Script Label palette is ignored. In this situation, 
the text disappears from the text box the next time the control is updated.

• Each threaded text frame can have its own tag, even though all are threaded together.

SD: Seems like a strange (But not 
necessarily bad) featurette. Is this 
by design?

• If a page item having a tag is selected when the Script Label palette is opened, the tag of 
the selected object appears highlighted in the palette text box.

• The palette text box has all the features of any text box. For example, users can drag 
over text in the box to highlight it; begin typing to add text or replace highlighted text; 
context-click in the box to Cut, Copy, Paste, or Select All text, or Undo the last text edit. 
and so on.

7.3 Initialization, 
states, and defaults

By default, the Script Label palette is not visible. Like most palettes, users can display the pal-
ette by choosing Window > Script Label. The text box is empty by default unless a tagged 
object is selected when the palette is displayed. The palette width is the same as all non-resiz-
able InDesign palettes.

7.4 Pointers/cursors The Script Label palette uses the following pointers.

7.5 Commands, 
keystrokes, and 
gestures

The Script palette uses the following commands and keyboard shortcuts.

8.0 Interaction with other features

The Script and Script Label palettes interact with other features in InDesign 2.0:

• Time permitting, users may be able to assign keyboard shortcuts to individual scripts 
in the Script palette. This may be done through the existing keyboard shortcut editor 
(choose Edit > Edit Shortcuts).

• In a sense, the Script Label palette duplicates features of the Tags palette. Unlike the 
Tags palette, however, the Script Label palette cannot assign tags to text but can assign 
different tags to each text frame in a threaded series. For more information, see the 
Cross-media specification on the InDesign 2.0 Interface Design intranet site.

Shape Name Use

Selection Indicates that clicking will select or otherwise prepare for further action.

Text Appears when the pointer is over the text box

Action Command or shortcut

Open the Script Label palette Window > Script Label
Tag a page item Select the item(s) and type the tag in the palette text box
Edit an existing tag Select tagged page item(s) and edit the text in the palette text box
Remove an existing tag Select tagged page item(s), activate the text box, and delete the text

http://indesign-projects.sea.adobe.com/anna/ui/pdf/an_crossmedia_v14.pdf
http://indesign-projects.sea.adobe.com/anna/ui/index.html
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9.0 Localization issues

The scripts that ship with the Script palette will not be localized.

10.0 Future enhancements

The following features may be added to the current or future versions of the Script or Script 
Label palettes as time permits:

Will this be done in Edit > Edit 
Shortcuts? Or will the palette 
have its own UI for keyboard 
shortcuts?

• Users may be able to assign a keyboard shortcut to a script in the Script palette (using 
Edit > Edit Shortcuts).

• The Script palette may have a palette (flyout) menu with some configuration options.

• The Script palette may use the operating system’s icons for items in the Script palette 
(i.e., palette items would have the same icon as seen in the computer’s file system).

• The Script and Script Label palettes may be merged into a single palette.

• The Script Label palette (or feature) may go away altogether to encourage users to use 
the Tags palette to tag items referenced in scripts.
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