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Display Performance

1.0 Revision history 

2.0 User Problem/Solution

This spec describes the UI for new optimization settings. These settings allow the user to 
control display performance and are designed to address known performance problems in 
the following areas:

• Placing raster images, PDF files, and EPS files

• Displaying graphics, particularly in high-resolution mode

• Displaying text

• Drawing transparency effects

3.0 Related specs

Anna functional specs:

• Image Display and Performance in Annapurna

Anna UI specs:

• Menus

• Context menus

Common UI specs:

• Transparency

Date Name Description of changes

11/00 J.Aguirre First draft
12/07/00
12/15/00 J.Aguirre Corrections and additions per Eng. (Dave Stephens).

05-04-01
05-09-01 J.Aguirre Updated per new mock-up from.

Changed spec title from “Optimization Settings” to “Display Performance.”
05-16-01 J.Aguirre Updated menus and changed “Ignore Local Settings” checkbox to “Ignore Local Display Settings.
07-11-01 J.Aguirre Corrected Transparency slider setting descriptions; added “Use View Setting” to the context menu for selections.
07-12-01 J.Aguirre Added “Clear Local Display Settings” to the context menu.

http://indesign-projects.sea.adobe.com/Anna/Documents/Functional%20Specifications/Layout/DisplayPerformance.pdf
http://indesign-projects.sea.adobe.com/anna/ui/pdf/an_menus_v01.pdf
http://indesign-projects.sea.adobe.com/anna/UI/pdf/ID2_context_menus_v6.pdf
http://indesign-projects.sea.adobe.com/anna/ui/pdf/transparency_v04.pdf
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4.0 Conventions

This document uses the following keyboard equivalents: 

Context-click refers to the gesture on both platforms that displays a context menu. In Win-
dows, this is a right-click; in Mac OS, this is a Control-click.

5.0 User interface

5.1 InDesign 1.5 
implementation

The InDesign 1.5 General Preferences dialog includes the following display settings:

Figure 1: InDesign 1.5 image display preferences

5.2 General The new display performance user interface includes the following changes:

• Introduce the Display Performance preferences panel (see section 6.0).

• Remove the Image Display settings in the General Preferences dialog (see section 5.1).

• Remove the Proxy Image Resolution setting from the Image Import Options dialog 
(the Show Import Options checkbox must be checked in the Place dialog to see the 
Import Options dialog). 

Instead of a proxy mode, we’ll provide a Fast mode with a default resolution of 72 dpi. 
This reduces the need to switch to High Resolution mode.

• Remove the Anti-Aliased Type setting from the Text Preference dialog. This is now an 
option in the Display Preferences panel (see section 6.2.4).

• Add View and Object menu commands for overrides (see sections 7.1 and 7.2 for 
details).

Key in Windows Key in MacOS

Alt Option
Ctrl Commanda

a. The Macintosh Control key is used in the Adobe user interface standards 
only in the Control-click gesture to access context menus.

Enter Returnb

b. Also the Enter key found on the numeric keypad on both platforms.
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6.0 Display Performance preferences panel

The Display Performance preferences panel is now available from Edit > Preferences:

Should the order of commands 
on this menu match the order in 
the panel list (or vice versa)?

Figure 2: Edit >Preferences > Display Performance

The new panel includes settings for the default view as well as customization options for the 
view settings themselves:

Figure 3: Display Performance panel with default settings

The default view preferences are set for Typical performance, as shown here. 

Users can set display values for each of three groups—Optimized, Typical, and High Qual-
ity—by using the radio buttons at the top of the Display Settings group. Settings are then 
applied as a group to a view (see “View menu”). Rather than setting a local override for image 
display at the object level, a local override can be applied to assign a group of settings to an 
object (see “Object menu”).

These display settings do not affect printed output but do affect the quality and performance 
of screen display. The following sections describe these new settings in detail.

6.1 Default View 
Settings group

The pop-up menu sets the default view (see “View menu”) for the document. Choices are 
Typical, Optimized, and High-Quality. The default is Typical.
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6.1.1 Ignore Local Display Settings checkbox
When this is checked, object settings (see “Object menu”) are overridden by the default view 
settings. The Object> Display submenu commands are disabled to indicate to the user that 
local overrides have no affect and all page items are drawn with the document (i.e., View 
menu) settings. Unchecked by default.

6.2 Adjust Display 
Settings group

Click on a radio button—Optimized, Typical, or High Quality—to set values for each of 
these groups. These customized settings can be applied on a document or object level. 

When you click a radio button, the default settings for that view appear. For example, in 
Figure 3 on page 3, the Typical defaults show (Proxy/Proxy/Medium Quality on the sliders, 
anti-aliasing is on, and Greek Type Below is set to 0 pt). The default view settings of each con-
trol are described next.

6.2.1 Raster Images slider
Controls the display of bitmap images in a document.

Optimized: The setting is Gray Out; images are drawn as gray boxes.

Typical: The setting is Proxy; images are forced to proxy resolution (72 dpi).

High Quality: The setting is High Resolution; images are drawn at the maximum resolution 
supported by the monitor and current default view setting (see “Default View Settings 
group”).

6.2.2 Vector Graphics slider
Controls the display of resolution-independent graphics. 

Optimized: The setting is Gray Out; graphics are drawn as gray boxes.

Typical: The setting is Proxy; graphics are forced to proxy resolution (72 dpi).

High Quality: The setting is High Resolution; graphics are drawn at the maximum resolu-
tion supported by the monitor and current default view setting (see “Default View Settings 
group”).

6.2.3 Transparency slider
Controls the display of transparency in a document.

Optimized: The setting is Low Quality. Basic transparency (opacity and blend modes) are 
displayed, and transparency effects (drop shadow and feather) are shown in a low-resolution 
approximation. However, in this mode, page contents are not isolated from the background 
and the blending space is always RGB. This means that objects with blend modes other than 
Normal might appear different than in other applications, and may differ from the final out-
put. Therefore, this mode should be used with caution (Medium or High Quality modes 
should be made for final design decisions.)

Typical: The setting is Medium Quality. This mode is recommended for most work unless 
the document is particularly transparency-heavy or has many transparency effects. Page con-
tent is isolated from the page background so blend modes appear correctly. Effects are ren-
dered at screen resolution (72 dpi). 

High Quality: The setting is High Quality. This mode is like Standard except that it increases 
the effects resolution on screen to 144 dpi for a more accurate appearance when zoomed at 
more than 100%. In addition, when the document blending space is CMYK and you are 
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either soft-proofing or have enabled overprint preview mode, opacity matting is done in 
CMYK rather in RGB. This means that partially transparent CMYK colors display as they 
would if they were tinted in CMYK, which is what happens when printing to a CMYK device. 
By contrast, in lower performance settings, these colors are tinted after being converted to 
RGB, which is faster but not as accurate. 

There is also the option to turn Transparency Off by dragging the slider all the way to the left 
(to the Better Performance side). In this case, no transparency effects are shown. This option 
is not part of the default view settings (you don’t ever get it by clicking a radio button); it is 
set manually.

6.2.4 Enable Anti-Aliasing checkbox
This setting controls not only text but also stroke, fill, and page items. For example, if text is 
converted to outlines, then the resulting outlines can be anti-aliased.

Optimized: Unchecked.

Typical: Checked.

High-Quality: Checked.

6.2.5 Use Defaults
This button resets all controls back to the default settings (see Figure 3 on page 3 for the Typ-
ical view default settings).

Are there errors for invalid 
values?

6.2.6 Greek Type Below 
This setting improves performance when there are many text attributes applied, or when 
there is a stroke. All type with an effective point size (i.e., point size * view scale) less than the 
valued entered in this field is greeked.

Optimized: The setting is 7 pt.

Typical: The setting is 9 pt.

High-Quality: The setting is 0 pt.

6.3 Behavior When you move among panels in this dialog, changes are retained until you click OK or Can-
cel. When you click OK, all changes made (in any panel) are saved and the Preferences dialog 
closes. When you click Cancel at this panel, all changes (in any panel) are lost and the Pref-
erences dialog closes. 

7.0 Menu changes

7.1 View menu New commands to switch among display performance settings have been added to the View 
menu. These commands are always available.
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See the Menus spec for 
accelerator keys (Windows only).

Figure 4: New display performance commands on View menu

7.1.1 Optimized Display
Uses Optimized settings for this view.

7.1.2 Typical Display
The default. Uses Typical settings for this view.

7.1.3 High Quality Display
Uses High Quality settings for this view.

7.1.4 Ignore Local Display Settings
This toggles object-level display settings on/off. Object-level settings are on by default.

7.2 Object menu The following commands will be added to a Display submenu on the Object menu to allow 
for local overrides. The Display submenu (and the commands on it) are not available if 
“Ignore Local Settings” is checked in the Display Performance preferences panel.

Figure 5: Object > Display Performance command

Figure 6: Object > Display Performance submenu 

7.2.1 Optimized Display
Uses Optimized settings for this object.

...
Actual Size
Entire Pasteboard

✔

Optimized Display
Typical Display
High Quality Display

Ctrl+F1
Ctrl+F2
Ctrl+F3

Ignore Local Display Settings

Display Master Items
...

...
Reverse Path

Display Performance

Optimized Display
Typical Display
High Quality Display

✔ Use View Setting
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7.2.2 Typical Display
Uses Typical settings for this object.

7.2.3 High Quality Display
Uses High Quality settings for this object.

7.2.4 Use View Setting
Uses the settings (Optimized, Typical, High Quality) that are set for the view (document). 
This is the default setting.

7.3 Context menus The commands to switch between display performance settings are also available from the 
Display Performance command on the context menus, as shown in the following figures. 
The Display Performance submenu is always the last command on the context menu. See the 
Context menus UI spec for details.

The following context menu is displayed when no page items are selected (the commands 
operate on the document):

Figure 7: Display Performance submenu with no selection

The user can toggle local overrides on/off with Ignore Local Display Settings. The following 
context menu is displayed when there is an object selected (the commands operate only on 
that object):

Figure 8: Display Performance submenu with a selection

8.0 Interaction with other features

Does the Links panel need to give feedback about object-level overrides?

✔

Optimized Display
Typical Display
High Quality Display

Ignore Local Display Settings
Clear Local Display Settings

✔

Optimized Display
Typical Display
High Quality Display

Use View Setting

http://indesign-projects.sea.adobe.com/anna/UI/pdf/ID2_context_menus_v6.pdf
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9.0 Localization issues

10.0 Documentation issues 

11.0 Future enhancements

Note: Design ideas in this section are not being implemented for Annapurna.
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